Thread Rating:
  • 53 Vote(s) - 4.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
Hi guys,
I have a problem.
Using Zadig my ps3 controller works via bluetooth but I notice that the bluetooth of my pc disappears and to reuse it I have to reinstall the drivers.
It's wearisome to do always this process and I'd understand a way for avoiding it.
Thanks
Reply

Sponsored links

(08-27-2015, 06:06 PM)Guastaferro98 Wrote: Hi guys,
I have a problem.
Using Zadig my ps3 controller works via bluetooth but I notice that the bluetooth of my pc disappears and to reuse it I have to reinstall the drivers.
It's wearisome to do always this process and I'd understand a way for avoiding it.
Thanks

Sadly that's just how it works. I really, REALLY wish there was just a program we had to run to temporarily load the DS3 drivers for bluetooth which unloads them when you close the program so we can use our BT dongles for other devices as well..
Reply
(08-28-2015, 05:27 AM)genesisboy Wrote: Sadly that's just how it works. I really, REALLY wish there was just a program we had to run to temporarily load the DS3 drivers for bluetooth which unloads them when you close the program so we can use our BT dongles for other devices as well..

Thanks for the reply.
So there is no alternative way to use controller via bluetooth?
Reply
(08-28-2015, 12:48 PM)Guastaferro98 Wrote: Thanks for the reply.
So there is no alternative way to use controller via bluetooth?

The alternative is to buy a bluetooth dongle and/or adapter.  Check out your favorite online shop, on amazon they are $3-$10 depending on (i dont know what) things.  I believe you want to make sure it has "EDR" standardized tech.  Just putting this out there because it sounds like you somehow have the controller connecting to your PC's internal bluetooth system.
Reply
Hi,

I've switched to this from MotionInJoy. I have a couple of issues though. They are probably interrelated:

1. Only Force install works. I'm on Windows 8.1. Plain install doesn't seem to install one of the items. I tried running as admin etc.
2. After I succesfully install, I can play for a while, after which something goes wrong, and the conrollers won't connect anymore.

Ifr I start SCP Monitor, it says:
Host address: <error>.

This practically means that I reinstall every time I want to play. Which could be bearable, but.. see next.
3. Sometimes install says that a reboot is required, and after the reboot, it won't work again (see point 2 above). So I frantically uninstall and reinstall, and somehow I usually manage to install without the reboot requirement.

But it is all too stressful as it is. It would be so nice if it just worked. Smile
Reply
Issue: No button input is being sent/received over Bluetooth. Controller is connected and rumble test still works in ScpUser.exe. Bluetooth dongle is brand new and controller sends input fine over USB. Reboot doesn't fix the problem.

OS: Win10 64-bit
SCP version: 1.2.2.175
Controller model: CECHZC2E A1
Bluetooth model: USB\VID_0A12&PID_0001
HCI/LMP Version: 3.0c5c

I read that "BTH 00000000 None" in SCP Monitor might mean that the dongle isn't EDR-compliant but the dongle has EDR in the product name and "Bluetooth V2.0 + EDR compliant" in the description so I know it's not that. Any ideas?
Reply
Hi everyone,
I've been having a issue lately with the controller and i don't know what it is, but here's what started happening:

While playing the controller disconnected itself and reconnected back after just a second, at first i thought it was the cable, so i tried switching cables but the problem persisted, then i discovered that it didn't disconnect randomly, it only disconnected only when i pressed X (weird). I tried reconnecting the controller a few times, rebooting the pc, reinstalling SCP Server, reinstalling Xbox 360 drivers, but the problem continued. After a while the controller stopped working completely, i have no idea what it is, please help.

EDIT: I managed to fix it, but i still don't know the origin of the problem (maybe a corrupted file on ScpServer folder).

What i did was:
1. Uninstalled ScpServer
2. Deleted ScpServer folder
3. Downloaded all the files again (version [1.2.0.160] and the update [1.2.2.175])
4. Force Installed ScpServer using ScpDriver.exe

The controller started to magically work again! Button inputs were working.
i suggest doing this even if you're using bluetooth.
Reply
New MotherBoard this time around but....
Code:
SCP Driver Installer 1.2.2.175 [8/29/2015 12:20:41 PM]

Detected - Microsoft Windows 7 Home Premium (6.1.7600.0 AMD64)
Selected WIN7 configuration.

SUCCESS - Virtual Bus Created
INFO    - ENTER:  DriverPackageInstallW
INFO    - Looking for Model Section [SCProductions.NTamd64]...
INFO    - Installing INF file 'C:\DS3 SCP\ScpServer\bin\System\ScpVBus.inf' (Plug and Play).
INFO    - Looking for Model Section [SCProductions.NTamd64]...
INFO    - Installing devices with Id "root\ScpVBus" using INF "C:\Windows\System32\DriverStore\FileRepository\scpvbus.inf_amd64_neutral_21ca245c0e23d7a5\ScpVBus.inf".
INFO    - ENTER UpdateDriverForPlugAndPlayDevices...
SUCCESS - RETURN UpdateDriverForPlugAndPlayDevices.
INFO    - Installation was successful.
SUCCESS - Install completed
INFO    - RETURN: DriverPackageInstallW  (0x0)
INFO    - ENTER:  DriverPackageInstallW
INFO    - Looking for Model Section [SCProductions.NTamd64]...
INFO    - Installing INF file 'C:\DS3 SCP\ScpServer\bin\System\Ds3WinUsb.inf' (Plug and Play).
INFO    - Looking for Model Section [SCProductions.NTamd64]...
INFO    - Installing devices with Id "USB\VID_054C&PID_0268&REV_0100" using INF "C:\Windows\System32\DriverStore\FileRepository\ds3winusb.inf_amd64_neutral_15691982ca5c21ae\Ds3WinUsb.inf".
INFO    - ENTER UpdateDriverForPlugAndPlayDevices...
SUCCESS - RETURN UpdateDriverForPlugAndPlayDevices.
INFO    - Installation was successful.
SUCCESS - Install completed
INFO    - RETURN: DriverPackageInstallW  (0x0)

Install Succeeded.

-- Install Summary --
Bus Device
Bus Driver
DS3 USB Driver

As you can see, the service isnt installing, did i need to boot Win 7 in a certain mode to accept the new service?


EDIT: Nvrm, got it installed, you should stress the need for the Visual C 2013 x86 redist, installing the x64 doesnt cut it
[Image: signature.png]
"A celestial descends onto Earth to give advice.
Buuuut, for me they're all advice that can't be put to action."  -Tenshi Hinanawi

FX-6300 @ 3.5 GHz; 16GB 1333MHz; GB 990FXA-UD3 R5; EVGA GTX 750 Ti FTW ACX
CPU: 7.4; GPU: 7.7 RAM: 7.5 HDD/SDD: 7.6
Reply




Users browsing this thread: 21 Guest(s)