Thread Rating:
  • 54 Vote(s) - 4.76 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
(05-14-2017, 02:54 AM)Spoodah Wrote: I have everything set up and everything is working. The only problem is that when I'm in game it shows the layout for an Xbox 360 controller. Anyway i can make it to show ps3 buttons? I don't know if it's because my computer thinks it's an xbox controller or what. Thank you so much.

Your computer does think it is a Xbox 360 controller that is how it works.  It tricks your computer into thinking it is a Xinput controller (ie an xbox 360 controller).  To make the layout show that it is a PS controller you would have to edit the game itself since the vast majority expect it to be a xbox controller.  You might be lucky and someone might have made a mod for you though to just change the artwork. (depends on the game, if modding is possible and if anyone cared enough to do it)
Reply

Sponsored links

I was able to use USB cable and BTH with host address (use Radig) show up but when booting up my laptop the host address indicate "error" causing BTH not working anymore. And I need to uninstall/reinstall again. Have anyone encounter to this issue ?
FYI,
OS: Windown 10 - 64bit
Intel wireless bluetooth - built-in device
Reply
is it possible to turn off the bluetooth dongle LED? because when it connects to the dualshock it blinks to a really annoying rate
Reply
it does not work anymore after new windows update, anyone know a fix?
Reply
Exclamation 
.....
Reply
(05-27-2017, 03:14 PM)goldfox2000 Wrote: it does not work anymore after new windows update, anyone know a fix?

I had an issue about three or four weeks ago where on my Win10 PC the ScpService wasn't recognizing my bluetooth dongle correctly anymore, and I assumed it was a recent windows update. When viewing the device's events in Device Manager, it said that my "Device (blah blah USB ID stuff) was migrated" on 4/30/2017 and followed shortly by installing driver btcusb.inf drivers overtop. I don't believe I had done anything in particular with the dongle hardware or SCP software that day.

I procrastinated fixing it until today. To get it to work again I uninstalled through ScpDriver.exe and after a few failed install attempts on getting "bluetooth driver" to appear on the install summary while the force install settings was "off" (I don't recall usually needing that before) I tried again with force install "on" and the "bluetooth driver" successfully installed that time.

I also appeared to have to run the zadig.exe steps again to get it to recognize my PS4 controller, but that went flawlessly and I'm back in business now.

Assuming you had any of the same exact issues I had, these steps appear to fix them.
Reply
Hi,
I have installed the SCP package today and my PC detects correctly my DS3 and I can currently play with it by USB.
But I have 2 problems :
-I can't control my PC with my DS3 without the USB link/connection (in Bluetooth in fact), maybe I don't have the latest version of SCP server
-When I want to stop to play with my DS3 on my PC, I disconnect the USB link and then, my PS3 switch on, even if I don't press the PS button. However, I reset my DS3 with reset button (on the bach of the DS3). It disturbs me because the PS3 is in my brother's room. I tried several configurations of SCP Driver (Bluetooth Driver On/Off and Force Install On/Off) but it doesn't work

Could someone help me ?
Thank you
Reply
Hey guys. This worked perfectly until I installed Windows 10 Creators update. Now the SCP Monitor isn't recognizing the controllers anymore. I can hear the sound when I insert any of my 3 PS3 controllers, but I can't use them in games. Before that my computer recognized all of my controllers as Xbox controllers. Even bluetooth worked. On my brothers PC SCP is still working, he hasn't upgraded to Creators update yet.

I tried uninstalling, reinstalling, deleting drivers, reinstalling the drivers, frameworks, I deleted the whole SCP folder, downloaded it again, but nothing helped.

Anyone else having this problem?
Reply
Hey guys,

Currently im facing a very minor problem. I have recently installed the latest version of SCP Driver, With that i began to use a official Ps3 controller, which seem to be recognised as a Xbox Controller, this also ends up happening in every single game that have played thus far. Being a Ps3 gamer this really messes  mental adjustment. I was just wondering if anyone has a solution for this problem, or if youll can redirect me to a previouse known solved case. it would be much appreciated.

Thnks.
Reply




Users browsing this thread: 21 Guest(s)