Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XenoSaga recommended settings.
#1
Now I have a system capable of playing this!(Really, insanely much more so, before, at the same intro scene I had 60-70FPS and it dipped under 45, down to 30 at some fights later on.

I did a quick test and I got 120FPS...for the majority of these same scenes. Totally nuts! Viva la Sandy Bridge, and CPU usage was at 30% normal speed, @ 120FPS though it was 70% and 60% GPU(2048 x 2048)

Anyways, the settings I have now are pretty default, DX11, the MTVU hack enabled, basically it, running at stock. Using the AVX version of GDSX. (Thanks again, Sandy Bridge)

So besides one tiny issue, XenoSaga looks perfecto-mundo. I notice odd lines at the edge of the screen during videos; that were not there in my previous version(4918), using 5037 now. I can deal with those, but then there is odd SPS, I guess the best way to say it, on the character models. Tiny little black lines dropping down around their edges, I saw it on my old rig to.

I thought I remembered hearing something about "enabling 8bit textures" so I did, but didn't see any change.

Is Software the only way to fix it? Cause it's been awhile, but I don't remember this back in 2008 when I first tried it, however, that was also 4 years ago...so, I'm willing to say I may have forgotten.


SPEED isn't the issue here really, just the little little black lines seemingly dropping off from around their character model.
Core i5 2500K @ 4.5GHZ, 8GB RAM 1866MHZ, 1080 GTX Strix, 128GB Samsung 830 SSD + 1TB Samsung 850 Evo SSD +  2 1TB HDDs.) Windows 7 64-bit Professional
Reply

Sponsored links

#2
Have you tried the very latest SVN, r5068?

There was some talk of SPS being fixed recently (see r5062 and after).
Maybe that'll help you. Smile
Reply
#3
Quote:but then there is odd SPS, I guess the best way to say it, on the character models. Tiny little black lines dropping down around their edges
It's badly emulated shadows and it has been there forever. They look correctly only in software mode. To get rid of them in hardware mode skipdraw 1 (or 2 don't recall)
[Image: newsig.jpg]
Reply
#4
Ah, I had the latest already, I was just looking @ the .exe which still says 5037. Skipdraw 1 got rid of it.

Really nice, running @ 3x Internal resolution with 4xMSAA and still achieve 120FPS. I bumped it up to about 4x and got around 90FPS, but didn't perceive to much of a noticable upgrade past that, so yeah.
Core i5 2500K @ 4.5GHZ, 8GB RAM 1866MHZ, 1080 GTX Strix, 128GB Samsung 830 SSD + 1TB Samsung 850 Evo SSD +  2 1TB HDDs.) Windows 7 64-bit Professional
Reply
#5
(01-16-2012, 02:45 AM)Bositman Wrote: It's badly emulated shadows and it has been there forever. They look correctly only in software mode. To get rid of them in hardware mode skipdraw 1 (or 2 don't recall)

use direct3d9 instead, you get other issues by skipdrawing in these games.
Reply
#6
I tried D3D9...same issue was present there with the black lines.

*Noticed something odd. I put Native x4, which before was 90FPS and now I get 120FPS again. What does the SkipDraw hack do, what has it removed? Obviously performance increased due to something being removed.

Ah, I see...shadows are gone...hrm..no other way than Software, eh? What else disappears, besides Shadows?
Core i5 2500K @ 4.5GHZ, 8GB RAM 1866MHZ, 1080 GTX Strix, 128GB Samsung 830 SSD + 1TB Samsung 850 Evo SSD +  2 1TB HDDs.) Windows 7 64-bit Professional
Reply
#7
with skipdraw?

post process effects, lights can flicker (in combination with offset hack)
Reply
#8
You're talking about Xenosaga 3 Squall, 1 did not have these stuff.
[Image: newsig.jpg]
Reply
#9
2 and 3 xD

yeah, just remembered, skipdraw fixes the line issues on 1, though so does the dx9 alpha hack :\ (it did at one point atleast)
Reply
#10
You may also have to toggle the FBA setting in DX9 mode, iirc.
Reply




Users browsing this thread: 1 Guest(s)