Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga 1 openGL blending options issue
#1
Hello, perhaps someone could help me out with a slight problem I have. In Xenosaga I in the first conversation cutscene between KOS-MOS and Shion, framerates tank whenever blending accuracy is turned on. However, when the scene changes during the cutscene, it returns to the normal framerate. during the slowdown, EE, GS, and VU values drop to the 40s, even with the frame limiter turned off but it shoots back to the 90s in the scene change.

Switching between basic and full in the blending accuracy unit results in the same framerate during the slowdown, which is roughly 56-57 fps. turning the blending accuracy off removes the slowdowns though i do wonder why the EE, GS, and VU values aren't maxed out during that section. note the values of the EE, GS, and VU on the pcx2 window on the screenshots.

6700hq, 970m
using the git build v.1.5.0-dev-1595-g259521e
no speedhacks enabled except for MTVU

Blending unit off
   
Blending unit basic
   
blending unit full
   
scene change
   
Reply

Sponsored links

#2
make sure your power scheme is set to max power, my old i7 920 ran with a 660 gtx 99% all scene full speed short of hand full threw out the game. @ 3x scale and majority of shader options on in GSDX shader

Would also make pcsx2 profile in nvidia control panel and set it to max performance. I dont trust Speedstep or any power saving features . I have seen GPU speeds reduce cause driver thought Pcsx2 didnt need it and seen Speedstep drop CPU speed to idle speed in pcsx2 and many other programs which always resulted in performance being reduced.

One thing to consider is scenes that ran Full speed with OpenGL some times dont run fullspeed with DX11 and Vis versa. Meaning for some reason Some scene ran better in one DX11 while that same scene in OpenGL ran worse.
Reply
#3
(11-14-2016, 09:45 PM)tsunami2311 Wrote: make sure your power scheme is set to max power, my old i7 920 ran  with a 660 gtx 99% all scene full speed short of  hand full threw out the game. @ 3x scale and majority of shader options on in GSDX shader

Would also make pcsx2 profile in nvidia control panel and set it to max performance. I dont trust Speedstep or any power saving features . I have seen GPU  speeds reduce cause driver thought Pcsx2 didnt need it and seen Speedstep drop CPU speed to idle speed in pcsx2 and many other programs which always resulted in performance being reduced.

One thing to consider is scenes that ran Full speed with OpenGL some times dont run fullspeed with DX11 and Vis versa. Meaning for some reason Some scene ran better in one DX11 while that same scene in OpenGL ran worse.

it's always set at max performance, both for the power settings and the nvidia geforce preferences. i'm not really worried about the speed issue since i can run it at full speed no problem. i'm just curious as to what causes the fps drops as from my understanding, having the framelimiter off will force the emulator to render frames as quickly as possible. that's why EE, GS, and VU values max out, depending on which bottlenecks the emu, the CPU or GPU. i just find it strange that even with the limiter off, there are some scenes where the EE, GS, and VU values don't max out, meaning that the hardware isn't being utilized fully.
Reply
#4
Something is wrong. There is a 4th thread called the driver, you don't see the % of usage but it is likely at 100%.

Are you sure that you run a 1.5 git and not 1.4. Did you enable any HW hack. Basic blending must be faster than Full blending.
Reply
#5
(11-15-2016, 12:33 PM)gregory Wrote: Something is wrong. There is a 4th thread called the driver, you don't see the % of usage but it is likely at 100%.

Are you sure that you run a 1.5 git and not 1.4. Did you enable any HW hack. Basic blending must be faster than Full blending.

why in me only can see EE and GS

How to show VU and Thread ??
Reply
#6
(11-15-2016, 01:57 PM)NewbieEmulator Wrote: why in me only can see EE and GS

How to show VU and Thread ??

That appears after you enable the MTVU speedhack.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
However we can't query the time in the driver thread (neither the time waiting the GPU to do its work)
Reply
#8
Yeah, it looks like the graphics driver or the gpu itself is just struggling as you up the blending accuracy, that is quite a hit at the basic level though.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
Exactly but code was optimized for Xenosaga on the basic level. The game uses a fbmask on the alpha channel but in this case, I don't split the draw call. I need to check my dump.
Reply
#10
(11-15-2016, 12:33 PM)gregory Wrote: Something is wrong. There is a 4th thread called the driver, you don't see the % of usage but it is likely at 100%.

Are you sure that you run a 1.5 git and not 1.4. Did you enable any HW hack. Basic blending must be faster than Full blending.

hello gregory, yes, it's a 1.5 git that i'm using. no hardware hacks turned on while testing. strangely enough, i tried running it both on the integrated graphics card and the 970m and framerates were just about equal, with probably a difference of 1-2 fps during the slowdowns. hope this additional info helps.
Reply




Users browsing this thread: 1 Guest(s)