Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga 3 visual issues :(
#1
Hello! I have used the forums to find solutions for my problems with configuring games in the past, but this is the first time where all solutions have not yielded the results which I want =/ Thus, this post. All X3 threads which I have seen were quite old, as well, and I have the current version of PCSX2. My first issue is with a rectangular shadow which follows the main character as they move around, distorting the ground visuals. This only started when I showed up to meet Allen, fairly early into the game. In the following two images, it may not be noticeable here, but it is obvious while moving, and it is incredibly annoying of a graphical error. Shion has varying grey rectangles around her in the first image which are not too bad to look at when stationary but are disruptive when actually playing, and I stood Shion in the centre of that plaza to show it diagonally cutting through it in the second image.
   
   

My next issue is with bloom in lighting effects; it is far too bright, and it causes a visual mirroring to a minor degree around the lights. This persists in cutscenes and in gameplay.
   
   

All attempts to tweak settings have not resulted in resolving either shadow box issue or the bloom. My current settings and specs are below, and since I am not sure what helps and what does not, here is possibly too much information:
   
   
   
   
   

Any assistance would be greatly appreciated since I emulated this far into the series and subsequently cut off many hours of waiting on loading via PCSX2 instead of my PS2 :) Oh, and the game itself runs absolutely fine as far as FPS goes; it is just these two problems which keep me from being able to really enjoy it more. I am not willing to play native due to the quality, either--at least 2x is where I draw the line, but I run all games at 4x normally.

My comp is Windows 7 64 SP1, AMD-6300 3.5GHz six-core, 8g RAM, and an NVIDIA GTX 760.
Reply

Sponsored links

#2
from an old compatibility thread (you cant see)

Quote:GSdx HW: Some scenes have bad looking postprocessin, skipdraw=4 removes the postprocessing. Fine with software.
GSdx D3D10 HW: Some scenes are darker, seems fine in D3D9 and software modes.

You might also try the Agressive CRC hw hack.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(07-24-2014, 01:00 PM)refraction Wrote: from an old compatibility thread (you cant see)


You might also try the Agressive CRC hw hack.

I have done this. Software mode seems just as bad visually as native mode to me, though. Is there a way to run this in hardware mode and not have these issues?
Reply
#4
If software mode is still bad, you could try playing with the EE, VU clamping and rounding modes, see if changing any of them help.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
(07-24-2014, 01:11 PM)refraction Wrote: If software mode is still bad, you could try playing with the EE, VU clamping and rounding modes, see if changing any of them help.

I found the EE fix (which did not do anything by itself), but where would I find VU clamping and rounding modes?
Reply
#6
(07-24-2014, 01:15 PM)icn.arrival Wrote: I found the EE fix (which did not do anything by itself), but where would I find VU clamping and rounding modes?

the EE and VU clamping modes are under the EE and VU tabs.

The EE timing fix isn't something I said to change Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(07-24-2014, 01:19 PM)refraction Wrote: the EE and VU clamping modes are under the EE and VU tabs.

The EE timing fix isn't something I said to change Smile

Ohhh, oops. No wonder why it did nothing! I tried the combinations of normal (default), full, and extra / extra + preserve sign, but I did not notice a difference with any combination, same no results from rounding changes...is this just an unfixable issue? Sorry to be so nooby here; I have tried my damndest to fix it without help as a long-time user of PCSX2, but it is beyond me.
Reply
#8
Did you try the rounding modes?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
For the rectangular shadow i believe it has to do with the Alpha Correction (FBA) . Try to enable it at GSDX plugin. From what i can see in your pictures it is disabled. For the bright areas issues using native resolution partially fix the problem.
Reply
#10
dx9, alpha correction, 8 bits, texture filterings, no hack needed
you wont get better than this, ive tried all

There is the issues you cant fix with 1.2.1 :
- Light issues
- weird shadow sometimes
- Seems blurry on the map
- some stutters during cinematics or some fights

With the resolution x2 with no MSAA the shadow is almost perfect but when you go on x3 and more its buggy.
i5 2500k@4,9ghz / Gtx980 Msi Gaming / 2x SSD Samsung 840pro 256gb / Acer Predator 24" G-sync
Corsair K95 RGB / Logitech G502 Proteus Core / Bose Companion 2 Serie III
Old JRPG fan, experienced mmo player, PC hardware expert
Reply




Users browsing this thread: 1 Guest(s)