Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga Episode 1
#1
I'm having two problems with Xenosaga, just wondering if anyone else has had these problems or knows of a way past it?

1. the opening movie ran perfectly, as did everything until shion entered the machine and started talking to kos-mos, then the speaches got very slow and jumpy, now it just seems at times its running perfectly and at other times im getting this slow jumpy problem.
may be a settings problem but im not sure what to do.

2. i tried to save at the 2nd save point in the game (after exiting the machine) and it asked me to choose which memory card, not the in game asking, but the ps2 browser asking. once i choose it took me to the browser settings, like the system reset itself.

i just finished playing KH-RE:COM so i know my pc can handle games, but ive heard xenosaga is laggy.

if anyone know what i can do to fix these problems it would be a great help.

btw my specs are:
2.66GHz dual core pentium
2 gig ram
nvidia geforce 8600 gt
windows 7
Reply

Sponsored links

#2
All known problems... the game sent to BIOS at some save points and slowdown even in more powerful CPUs... sadly this game is too sensible to EE cyclerate and VU Cycle Stealing speedhacks, to the point of sound synch going totally astray (out of synch with the image).

to complicate, some save points have other functions, for now the only known workaround is: SState always before trying the save points, and pray Smile

If it goes to BIOS, reset the game and load from the SState, avoid that save point.
Imagination is where we are truly real
Reply
#3
good advice, never even thought of that, considering i did exactly that in KHs lol. at least the 2nd savepoint isnt far from the first, just skip a few CS's.

ok thanks for the advice, i'll try that. Smile
Reply
#4
Are you use ZeroGS? I try to use GSdx with software render and can save at 2nd savepoint and got more stable speed.
Gentoo Linux x86(chroot)
Intel Core2 Quad CPU Q6600 @ 2.40GHz
nVidia Geforce 8800GT
Reply
#5
(03-18-2011, 01:36 AM)Syraphin Wrote: 1. the opening movie ran perfectly, as did everything until shion entered the machine and started talking to kos-mos, then the speaches got very slow and jumpy, now it just seems at times its running perfectly and at other times im getting this slow jumpy problem.

I finally decided to play Xenosaga again using the latest SVN version and this problem is still present. For some reason certain cutscenes slow down extremely, even though there's not more on the screen than in others.

If you have a powerfull rig, the DX11 mode can get you past the 60FPS (full speed) mark, but DX11 suffers from numerous other GFX gliches throughout the game. Like hair or other background objects being rendered where they shouldn't, etc, etc.

If you think about playing the game, dont get discouraged by the first slowdown scene (the close up with Shion and KOSMOS at the beginning). It's one of the slowest scenes i've come across so far. During my first 6-7 hours game time there where only like 3 cutscenes that slowed down like that. Wich isn't really much in Xenosaga terms.

Here's a little comparison video i made for the occasion. Rolleyes



Personally i've decided to live with the occasional slowdown, the DX9 mode is much more stable.
CPU: Intel i7 2600k @ 4GHz
GPU: ASUS GTX580 @ stock
RAM: 8GB (2x4) DDR3 PC3-10600
MB: ASRock P67 Pro3
OS: Win7 Pro 64bit
Reply
#6
Hatman:
72FPS in DX11 mode in that intro is a really impressive number.
I'm getting 40FPS here on a 3.7Ghz E8400, just for comparison Wink
Reply
#7
Syraphin, look the GS percentage, if it gets close 100% it's a sign the 3D is pushing badly on your video card, try reducing the scaling if using it or try native mode.

That scene runs steady 60 FPS (limited of course, to me there is no real good running above or under the standard) under a 9600GT and Phenom 2 965BE stock speed and 2x scaling, without EE and VU sliders hacks.

The test was done at the 4571 SVN, I don't know how it performs under previous builds anymore. Ah, and DX10, there is still some slowdown with DX9 even with alpha correction disabled, and logarithmic Z is a killer. Both tested with texture filtering and "Allow 8 bits texture" enabled.

PS: skipdraw 1 seems to get rid of those strange vertical lines on the sprites, for those that can't live with them. To the extent I tested it, no game breaking or perceptible problems arose. Just remember such hacks should not be left active, they may break another game.
Imagination is where we are truly real
Reply
#8
Xenosaga is heavy on the geometry, unfortunately you will need more than 4.2Ghz (on a Core i7) to keep the battle scenes @ full speed once the mecha's have been summoned.
Reply
#9
I almost went through the entire game.
Just use save state before save game in save point.
<<< [AMD Phenom II x6 1090T 3.6 GHz][ASUS GTX275][HDD 5TB][8Gb RAM] WinXP (x86) & Win7 (x64) >>>
Reply
#10
Indeed, Xenosaga is one those games that loves to stress both CPU and GPU, both one at a time or together...
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)