Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga Episode 1
#1
Here's my specs first
Ivy Bridge I5-3570k 3.4GH
8GB RAM
AMD R9-280X

So with those specs everything was running fine besides some minor slowdowns in cut scenes until I got to JRs section and have 2 AWGS on my team which causes everything to massively slow down. I was wondering if there was anything I could do to improve the performance of AWGS being on screen.

PCSX2 1.2.1
GS Plugin Settings http://i.imgur.com/YqiOkvw.jpg
Emulation Settings http://i.imgur.com/Wb4TKrA.jpg

Also please refresh the page the links take you to it will make the image appear not sure why it doesn't show up the first time.

Any help from you guys would be appreciated!!
Reply

Sponsored links

#2
disable FXAA and HW hacks and try the game. if that still doesn't help then, provide your EE and GS values during slowdown.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
Thanks for the speedy reply! I will try that right now.
Reply
#4
Ok I disabled them both and it didn't help much its still pretty slow.

Slow down screen shot http://i.imgur.com/BOB4fOz.jpg
Refresh the page to see the screenshot.

Here are the values if you just want the numbers.
FPS 31 EE 24 GS 22 VU 24 UI 0
Reply
#5
your processor is not using it's full potential, make sure that you have set priority of pcsx2 to high in taskmanager and set windows performance plan to high in control panel. also, monitor the temps of your processor using a software like coretemp.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
I did what you tried and it made no difference. But I remember seeing a walk through video of xenosaga on pcsx2 and it was in 1080 with zero FPS problems. So I checked the guys video and he listed his settings for Xenosaga and I tried those settings which made all my problems go away with AGWS. It runs at a much faster high 40s with 2 AGWS on field. Thanks for the help though!!

I'll list them here and link the video
https://www.youtube.com/watch?v=6F1AQ3WLnAY
PCSX2 rev.5444

GSdx 0.1.16 rev.5442 AVX
Direct3D9 (Hardware)
6x Scaling
"Allow 8-bit textures" OFF (game runs much better with this off)
"Alpha correction (FBA)" unchecked
"Enable HW Hacks" checked
"Skipdraw" set to 1 and "Half-Pixel Offset" checked under HW Hacks

FXAA enabled (via PgUp key)

Recommended speedhacks & MTVU hack on.
Reply
#7
ahh, I see. maybe increasing the internal resolution made the GPU to use more of it's load on the GS and produce better results.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
(04-17-2015, 06:13 PM)ssakash Wrote: ahh, I see. maybe increasing the internal resolution made the GPU to use more of it's load on the GS and produce better results.

I didn't pump the resolution to 1080 lol.. it could DX9 runs better for xenosaga than DX10 or disabling 8bit textures lightens the load for AWGS. Whatever it was I am happy gamer now.
Reply
#9
(04-17-2015, 06:26 PM)williamjuly2004 Wrote: I didn't pump the resolution to 1080 lol.. it could DX9 runs better for xenosaga than DX10 or disabling 8bit textures lightens the load for AWGS. Whatever it was I am happy gamer now.

That's good. Some games on PCSX2 are screwy and some random twink fixes can pretty much fix the problem(s) anyone can have.

Either way, cool thing you found how to fix it.
Moe: [to Homer] And I'm pulling your favorite song out of the jukebox.
Homer: "It's Raining Men"?!
Moe: Yeah, not no more, it ain't. [throws the record out the window which lands into Smithers' car]
Smithers: Ow! [looks at the record] Ohhh.

what would ;e; do
Reply
#10
I have lesser system then your and Xenosaga runs fulls speed @4x 99% time with GSDX shader FXAA and most it other option on.

Make sure you have MTVU on make sure you have profile AMD card for pcsx2 set to max performance and make sure you either have Speedstep disable in the bios or your Min/Max processor state is set to 100% in power scheme

And turn off presets
only enabled recommended speed hacks.
turn off 8 bit textures
Reply




Users browsing this thread: 1 Guest(s)