Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga Episode1, double fps after some code changing?
#1
Truth is, the slowness of the fmv almost drives me crazy, fps sometimes goes to 30 even on my e7400(3.5G) and GTS 250 1gb rig.

So i just try to play around with the code, rasterizer, more precisely.
You know what i mean, RamaTongue

Without changing anything, just switch from 2817GSDX and the one i compliled myself,and i got some very interesting screenshot.

   

   

Knew that nobody understands these code better than dev, especially a newbie like me. So i assume there must be something out of my knowledge.

And by using that modified gsdx, it seems the arrows that should be on minimap disppeared, and look closer at Shion's eyes, something is missing too.

So i'm just asking is it really that much difference of speed by just turning off
certain effect? Or maybe the rasterizer making such a miracle because this is almost like 80% speedup alreadyWacko

Thanks Dev for making this wonderful emulator, you guy's rock.
Reply

Sponsored links

#2
If you want better fps for Xenosaga I, i suggest the 'safe' method is putting clamp to none (except in some rare places where you need them at normal), and maybe enable the 'other' speedhacks.

As you yourself said, changing things around in Gsdx without a good solid base in that emu and plugin programming might introduce gamebreaking bugs.

Also, any fps beyond 60 is wasted.
Reply
#3
You must've disabled a GS feature that's used in this game for highlights and reflections.
Seems it's the major cause for slowdown in it.
Reply




Users browsing this thread: 1 Guest(s)