Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga I problem
#1
I can get Xenosaga to work right on 0.9.6 of pcsx2 (everything looks and is normal with decent fps), but when I try and play it with the 0.9.7 version, it's slightly different.

I get decent fps still but the screen, objects and people keep blinking, not to mention their heads look like someone took a sledgehammer and caved them in.
I've tried to put the settings in 0.9.7 similar to my 0.9.6 version but it didn't work, I've tried both the ZeroGS and the GSdx video plugin but I get the same result... blinking misshaped things.

My settings on the 0.9.7 version are:

EE/IOP
Recompiler - Recompiler
Round mode: Chop/zero
Clamping Mode: normal
Flush to zero
Denormals are zero

VU's:

MicroVU - both
Round mode: Chop/zero
Clamping Mode: normal
Flush to zero
Denormals are zero

Frameskipping is off - I can run things decently without having it on.

EE Cyclerate: 2
VU Cycle Stealing: 0.8 (or 1)
mVU flag hack
mVU block hack
INTC Spin detection
wait loop detection

EE Timing hack gamefix

I'd like to play it on 0.9.7 so I hope someone can help and tell me what problem there is.
Reply

Sponsored links

#2
(04-15-2011, 12:38 AM)Reias Wrote: not to mention their heads look like someone took a sledgehammer and caved them in.

could you post a screenshot of that? Tongue

Also try without speedhacks or gamefixes.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I would post a screenshot of that but somehow, I fixed that problem... >.> how I don't know... but I can't say it's a bad thing, should it ever happen again, I'll be happy to post it up for you though ^^

Without the speedhacks and gamefixes the people and such stop blinking, now to find which speedhack or game fix is causing it...
Though I admit the title screen blinks still but eh, that doesn't matter much :3

Thank you very much, Shadow Lady

EDIT: Aha, I found it :3
Apparently, Xenosaga does not play nice with VU stealing...
Reply
#4
Yep VU cycle stealing isn't that nice to many games, best to keep it low if you're gonna use it but I don't think it helps xenosaga anyway.

Well, enjoy Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
:/ new problem.... although everything from my earlier problem is all fixed Laugh I seem to have a stuttering problem.
._.
I've played "trial and error" with the speedhacks and game fixes, since I thought it might be like my last problem but those didn't do anything (except slow it down) my fps is around 41 - 45, which is normal for me in xenosaga, the stuttering though, that's new but I think it doesn't like pcsx2 0.9.7... that or I can't configure the emulator correctly

Edit: Nevermind, I fixed it be clearing my settings and redoing everything :3 while slightly slow, it works ^_^
Reply
#6
Stuttering could mean all sorts of things. But you hould make sure timestreching is enabled in your spu config. And xenosaga reacts really really bad to VU cycle stealing.
CPU: Intel i7 2600k @ 4GHz
GPU: ASUS GTX580 @ stock
RAM: 8GB (2x4) DDR3 PC3-10600
MB: ASRock P67 Pro3
OS: Win7 Pro 64bit
Reply
#7
That was my first problem when the screen was constantly blinking. I think the stuttering was because I was using GSdx sse3.
Now I'm using sse2 and it's working as it should.
and by stuttering I didn't mean the sound, I meant the video part, it would skip every time I tried to take a step.

Sound I could care less about, I always have music playing when I use the emulator xD and have it muted
Reply
#8
(04-16-2011, 07:50 PM)Reias Wrote: ..and by stuttering I didn't mean the sound, I meant the video part, it would skip every time I tried to take a step.

Now that sounds like vu cycle stealing. XD

You got it on?


EDIT: Forget that. Brain fart. What i meant was frame skipping. Turn it off.
CPU: Intel i7 2600k @ 4GHz
GPU: ASUS GTX580 @ stock
RAM: 8GB (2x4) DDR3 PC3-10600
MB: ASRock P67 Pro3
OS: Win7 Pro 64bit
Reply
#9
nope I turned it off, But whatever it was, once I cleared my settings and redid my controls and such... everything is working... alot better than it was before.

And my new motto is... when in doubt reset settings
Reply
#10
Did you have any AGWS battles yet? Those are incredibly slow for me.
Like every AGWS you summon cuts FPS in half for some reason.
Haven't found a way to get them run properly, short of going DX11. And even then i barely get 50FPS. :/

CPU: Intel i7 2600k @ 4GHz
GPU: ASUS GTX580 @ stock
RAM: 8GB (2x4) DDR3 PC3-10600
MB: ASRock P67 Pro3
OS: Win7 Pro 64bit
Reply




Users browsing this thread: 1 Guest(s)