Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga II slowdowns
I played xenosaga 1 with 60fps all the way through. I use windows 7 and have an I7 920 at 3.4 and play directx 10 mode. When I tried xenosaga II the gameplay drops to around 4-7fps after the opening cut scene. I read on some other post that the awgs or E.S. parts of the game have slow downs but is there a setting that I can use to at least get better fps during those parts. Has anyone played through xenosaga II or is it just too slow at the moment?

Sorry I don't have all my settings with me, I'm at another computer but I'll do my best.
PCSX2 Beta 1059
gsdx 0.1.7
SPU2GHz 1.9.0
I use Direct X 10 and tried with native res checked.

I7 920 3.4
Geforce 8800 gts
Asus P6T Deluxe
3 gigs of ram
Windows 7

Sponsored links

pc specs, pcsx2 settings?
I don't mind skipping part II and going straight to III, but if someone else managed to get II working smoothly then I'll play around more and try to get a better fps during the problem parts.
So I tried on an earlier version Pcsx2_0.9.5 369 with gsdx 0.1.7 and things ran much better. Around
20-50 fps, which is much better.
You need better videocard for this game or set resolution to native.
For example, with my videocard i got stable 50-60 fps with 1024*800 resolution.
Phenom 1055T x6 3.5GHz ; nVidia GTS 250; 6Gb RAM; Windows 7 x64
i've same videocard and the game runs always at 60 FPS except for opening movie.
I use directx10

Oh my god, forgive me, i've Xenosaga III and not 2. my mystake :-(
I5 - 2320 @ 3,0 Ghz - 8 GbyteDDR2 1333 Mhz - Geforce 8800 GTS 512 Mbyte - Win 7x64 - Samsung 32" TV HD-Ready
Uomo saggio il cielo aiuta.
(05-14-2009, 04:12 AM)veggicide Wrote: So I tried on an earlier version Pcsx2_0.9.5 369 with gsdx 0.1.7 and things ran much better. Around
20-50 fps, which is much better.

It's a GSdx issue,try using gsdx 0.1.7 with the latest PCSX2 beta,that should give you max fps. Also,try lowering the internal resolution,that will help in the E.S. scenes.
Currently playing it myself Wink
[Image: newsig.jpg]
Can you all be a bit more specific with the settings used? I'm having the same slowdown problems currently.

My current PC specs are:
E8400 oc'ed to 3.44ghz
Radeon 4870
XP Home 32-bit, 3.25gb of ram

Current pcsx2 0.9.6 settings:
Renderer is Direct3D9 Hardware
Shader is PS 3.0
No interlacing
Aspect Ratio is 4:3
Texture filtering, Alpha correction, Nloop checked.
I dled gsdx 0.1.7 like recommended, didn't help one bit for that opening level. I checked native d3d resolution which brought it down to 512x448. Constant stuttering at 8-12fps. The opening cinematic seems to work fine, but the New Game/Continue game screen and gameplay is constant stutter at low, low fps. Kinda at a loss for what to do here.

ZeroGS also has serious stutter problems, but seems to have slightly better fps in the menus (it runs absolutely crisp in the menus on both plugins).
Since you have win XP, I recommend downloading Windows 7 so you can use DirectX 10 it will run faster.
Yep, this game is about 95% slower in DX9 hardware than it is in DX10 hardware.
So as JM0rrison said, you need to install either vista or win7 to enjoy it Tongue2

Users browsing this thread: 1 Guest(s)