Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga III Lighting Issue
#1
Skimmed through some old threads with search

Running in DX10 and everything works fine except when I approach NPCs the lighting shifts from dark to lit up suddenly.

I had to turn on frameskip to 3 already to get some odd lighting issues to go away that were there 24/7

There also some weird ghosting going on in all the prerendered cutscenes but its not an issue... the lighting is just starting to screw with me lol

I'm on an i7920 @4.2Ghz and GTX465 clocked past a 480 and can hit 90-150fps when I unlock it at 1080p so thats not an issue

I saw some reccomendations on DX9 with skip frames 4 and offset hack on but its causing a different issue in cutscenes and the lighting issue when approaching NPCs is still there

sorry if I'm bringing up an old topic, tried to search it, any help is appreciated
Reply

Sponsored links

#2
The lighting bug with DX10 Hardware mode in Xenosaga III (happens also in II) is a known issue and cannot be fixed, as far as I know. Maybe DirectX9 Mode fixes it, but it might cause other issues and slowdown.
The only thing I know about, that can be fixed with GSDX hacks, is the garbage in the opening FMV. To do this enable Offset Hack and set Skipdraw to 4. It did not fix the lighting issue though. I just accepted it, because it did not bother me too much.
Intel i5 3450
AsRock B75-Pro3-M
Sapphire R9 290 Tri-X OC
8GB DDR3-1333 RAM
Sandisk Ultra Plus 256GB
Seagate 7200.14 1TB x2
Enermax Triathlor 450W PSU
Reply
#3
(01-16-2011, 08:25 AM)xiph Wrote: Running in DX10 and everything works fine except when I approach NPCs the lighting shifts from dark to lit up suddenly.

Use D3D9 for this.


Quote:I had to turn on frameskip to 3 already to get some odd lighting issues to go away that were there 24/7

What lighting issues?


Quote:There also some weird ghosting going on in all the prerendered cutscenes but its not an issue... the lighting is just starting to screw with me lol

Use a scaling resolution (2x, 3x, 4x, etc) and enable offset hack.


Most compatible thing for this game would be using a (Software) renderer which would make it slower and less good looking.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
First off thank you all very much

I ended up with D3D9
4x scaling
offset hack
skip frames 3

The lighting issue I mentioned was odd rectangular lighting blocks extending out across the ground from the main character

Pumped to replay this game on my pc in a higher resolution, again I really appreciate the help

Also in case anyone searches and finds this the load times virtually ceased to exist when I made an iso of my disc instead of playing from the disc drive, definitely a requirement to enjoy the replay
Reply
#5
Maybe you can get away with no frame skipping (ewh, skipping Tongue2) by reducing the scaling to 2x.
Reply




Users browsing this thread: 1 Guest(s)