Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga III slow menus.
#1
Ok I've been messing with this game a lot and I finally have all the 3d running at a reliable 60fps. The only problem remaining is the menus are horridly slow.

Over the course of my testing I tried a lot of different things including finally OC'ing my CPU a considerable amount. None of that seemed to have any effect on the menus which have run at a pretty steady 30fps no matter what.

My current setup is:
E 8500 C2D @ 3.7 Ghz
8 Gigs DDR2 800 ram
Vista 64bit SP2
ATI Radeon 4870

I'm using the beta build + default plugins with gsdx SSE41 in DX10. I unchecked 8-bit textures (was slowing down the game oddly). I also have the res around 1280*1280 but lowering that does nothing.

I've tried all the different speed hacks but nothing seems to affect the menus. I figured this menu thing was a known issue or something but I can't find any info on it at all via my searching.

It's not like it's a huge deal but if anyone knows more info on the issue or if it's possible to fix it that'd be good to know.
Reply

Sponsored links

#2
Odd, this is one of the very few games that the 8-bit textures option was designed for... It should be off for 99% of games, but give xenosaga 3 a sizable speed increase.
[Image: 2748844.png]
Reply
#3
Make sure you use the latest beta GSdx as it has a fix for slowness on ati cards.
Also make sure you have vsync turned off (the issue sounds like it's that).
Reply
#4
(12-05-2009, 09:09 PM)rama Wrote: Make sure you use the latest beta GSdx as it has a fix for slowness on ati cards.
Also make sure you have vsync turned off (the issue sounds like it's that).

Vsync was off. I also tried the latest gsdx release and it wasn't any better. Still getting crazy lag in menus.

The bizzare thing is that if I turn on the software render then suddenly the menus run at full speed.

Do you guys not have this issue when you play it then? Maybe I should do a Gsdx bug report if it's not a common problem.
Reply
#5
Around 60fps here when using 4x upscaling, so no, don't need a bug report.
Unless this is some sort of ATI only problem again, which I doubt.
Reply
#6
(12-06-2009, 12:07 AM)rama Wrote: Around 60fps here when using 4x upscaling, so no, don't need a bug report.
Unless this is some sort of ATI only problem again, which I doubt.

That's what I was considering actually, that it might be related to the video card/drivers. No matter what res I pick it's the same yet in software rendering it works fine (60 fps easy).

It's not cpu bound so I get the feeling probably gsdx is being forced to wait on some quirky thing the video card is doing that it shouldn't. Maybe even a bug in the ATI drivers. I'd update them but I already have the latest ones.
Reply
#7
The menus are slow using "allow 8-bit textures" and using a high internal res but keeps the game running at stable speeds like this, turning 8-bit textures off will make gameplay very bad tho (will keep slowing down after a time until it becomes unplayable at some points).

How much of a slowdown on menus do you mean?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
Yea that's not mirroring my situation. I've 8 bit textures off and the game runs fine. Even if I use native res it's still insanely slow in menus.

By slow I mean out of menus I've got stable 60fps but as soon as I enter any full screen menu it instantly drops to 30~35 fps. The controls respond very slow and the sounds become distorted due to the slowness.
Reply




Users browsing this thread: 1 Guest(s)