Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga Question (About speed)
#1
I was trying Xenosaga I on PCSX2 today and I was wondering if the game was supposed to be really slow on the cutscenes. I read a couple posts saying that xenosaga is really heavy on ps2, but I was wondering about how much FPS I should be getting in cutscenes, especially when KOS-MOS comes out. As in usually, the frame rates are decent until KOS-MOS comes out and compeltely crashes thef rame rates, in addition to other cutscenes in the beginning.

So here's my specs
CPU: I7 quad core
Graphic: Ati Radeon 512mb 4850 (A bit weak is it?)
RAM: 6gb

Uhh... I don't think any other part is special.
I am using 2x cycling, with the INTC sync hack

Even with frameskip enabled, I get roughly around 30~35fps
Without frameskip(limit/normal) I get around 20~30fps

I am using the GSDX (directx10) with 800 by 600 resolution.

Are these frame rates normal? Or if possible, is there a good way to improve the speed?
Reply

Sponsored links

#2
Did you try this game with the latest PCSX2 beta? Tried checking the "native" option in GSdx? do you have the options in the cpu settings enabled?

It would help if you show us your PCSX2 settings.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
provide ur pcsx2 conf more.D3D internal res must be native.all cpu option must be enabled. VU skip should be used.
Reply
#4
Provide us of more information, and use the latest beta!
SAGER NP8690 | i7-620M 2.66Ghz | 6GB RAM | ATI 5870M 1GB GDDR5 | FullHD 1080p 15.6'' | 500GB HDD 7200RPM | WINDOWS 7
Reply
#5
I am using the latest beta 1474
GSDX
DirectX10(hardware)
Interlacing:None
Resolution:800x600, native not checked
Texture-Filtering:Auto
8-bit Text:Checked

Cycle:2x
INTC Sync Checked
Frame SKip on, default settings
The 2 microVU recompilation checked, and not-cehcked, tried all 4 combination

Computer:
Cpu: intel i7 cpu
Memory: 6GB ram
Graphics: ATI RADEON 4850, 512mb

PCSX2 Attributes: CPU 4~7
Frame Rate(On the first couple scenes where KOS-MOS appears) about 20~30 w/o Frame Skip, about 25~35 with frame skip
Reply
#6
I guess, you're using and old revision of Gsdx and the speed is suffering from "the ATI Issue" (xD)

Get some of the newest Gsdx revisions and try them.

Edit:

Wow, just readed this:

Quote:ATI problem was reintroduced in r1439

So, try to get some revision inmediatly under 1439
Reply
#7
it's not "the ati problem", it's a slowdown problem with some games on ati cards. r1402/1406 should be safe to use in this case. but try them against the latest revision to compare it yourself, as with some games the later gsdx revisions could even be faster on ati cards.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#8
yes thanks.................
Reply
#9
(07-23-2009, 02:00 AM)zero29 Wrote: it's not "the ati problem", it's a slowdown problem with some games on ati cards. r1402/1406 should be safe to use in this case. but try them against the latest revision to compare it yourself, as with some games the later gsdx revisions could even be faster on ati cards.

Alright, I will try that sometime tonight. Thanks!
Reply
#10
i have the same problem,
xenosaga 3 just keep on roughly on 45-50 fps
and i'm using pcsx 2655 gsdx 2817
i know my pc spec is not that good amd athlon x2 2.7ghz
onboard graphic card
oddly again, if i use frameskip in pcsx svn 2655 seems not working in xenosaga, but for other games show the differences..
Reply




Users browsing this thread: 1 Guest(s)