Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga - extremely low FPS
I have a little problem Xenosaga (I.) When I start it, everithing is fine. The Videos goes on max speed. The ingame cutscene's too, but they are extremely pixelous(more pixelous than the "native resolution"), and when I start to play, the image will be fine, but it goes around 14-16FPS. Dragon Ball Z Budokai 3 and Tenkaichi 3 runs on 30FPS.

The speed hacks doesn't works.
I "play" (if that 20 min was playing) from an ISO file (on my hard drive, so doesn't the slow disc reading is the problem)

My specs are:
Intel Core 2 Duo E7200 @ 2.55Ghz
Ati Radeon HD4850
Windows XP Pro SP2
Video plugin: GSdx 872m (with SSE4.1)

In the next month i will install Vista too because of the DX10. Now i would to ask: Does this game runs faster on DX10(Like Budokai Tenkaichi 3)? Or it's like the Mortal Kombat series (alway slow emulation) ? Oh, I forgot, the game is NTSC version.

Sponsored links

The game is in general extremely slow,and especially in the Playground builds.Seems the game hates some of the extra checks that are being done there.
Only way to play it with decent FPS: Use the latest PCSX2 revision (rev 390),custom-enable the denormals are zero hack through the source (you can search for it in the source,it has instructions there) and check ee/iop hack.
Also GSdx DX10 mode is a must
Still,I'm getting slowdowns in cutscenes to about 40 fps with my E8400 overclocked at 3,8 you can imagine that you'll never get 60 fps with your PC...
[Image: newsig.jpg]
I see... The ee/iop hacks were enabled and the denormals to zero were too...
I dont want full speed, 25-30FPS is enough for me (cuz of the game's genre). I will try it with vista too, maybe it will help.

The PCSX2 0.9.4 had the same FPS too. Did you say 40FPS during cutscenes? My cutscenes were 60+ FPS xD But it's like a kiss for a dead... (cuz the ingame is still unplayable for me xD)

But anyway thanks for the fast reply and have a nice day!
That's videos at 60fps not ingame cutscenes Tongue
I was talking about latest PCSX2 svn NOT playground ( ) which does not have a denormals are zero checkbox (it works way faster than any playground build with xenosaga)
[Image: newsig.jpg]
Yes, now i see... I misreaded your post. Ok, i will try with the source code. At least i will see it how it looks^^
With my current rig, max i got 31-32 fps in first cutscenes and battle. Still unplayable for me with that speed.
Phenom 1055T x6 3.5GHz ; nVidia GTS 250; 6Gb RAM; Windows 7 x64
The game NEEDS dx10 mode. It's like 300% faster with it (sometimes more).
(01-15-2009, 06:00 PM)rama Wrote: The game NEEDS dx10 mode. It's like 300% faster with it (sometimes more).

I already using DX10 mode but Xenosaga 1 still show me 28-34 fps Mellow
Phenom 1055T x6 3.5GHz ; nVidia GTS 250; 6Gb RAM; Windows 7 x64
Yeah, if you had a good pc however, then it'd be fullspeed in dx10.
It'd still only run at 20fps max in dx9 mode on such a pc. Thats what I'm saying Wink
So the Vista is good for something... I've never realized, that this day will come once...

Ok, i will switch to Vista. Thanx for the help!

Users browsing this thread: 1 Guest(s)