Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yakuza - vif1 force break?
#1
I'm running into a constant black screen with Yakuza after a while. I tried playing with the VU compiler options, but to no effect. The game is running on software mode (due to the blurry lighting effects @ native res) with GSdx32-SSE4-r5725.

Here is a sample log I recorded.

Quote:PCSX2 1.1.0.r5722 - compiled on Aug 28 2013
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build
7601), 64-bit
Physical RAM = 8154 MB
CPU name = Intel® Core™ i5-3570K CPU @ 3.40GHz
Vendor/Model = GenuineIntel (stepping 09)
CPU speed = 3.512 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7f9ae3bf
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\Games\EmuCR-Pcsx2-r5427\r5725\pcsx2-5725-windows-x86\plugins
\GSdx32-SSE4-r5725.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: C:\Games\EmuCR-Pcsx2-r5427\r5725\pcsx2-5725-windows-x86\plugins
\LilyPad-r5403.dll
Binding SPU2: C:\Games\EmuCR-Pcsx2-r5427\r5725\pcsx2-5725-windows-x86\plugins\SPU2-
X-r5695.dll
Binding CDVD: C:\Games\EmuCR-Pcsx2-r5427\r5725\pcsx2-5725-windows-x86\plugins
\cdvdGigaherz-r5692.dll
Binding USB: C:\Games\EmuCR-Pcsx2-r5427\r5725\pcsx2-5725-windows-x86\plugins
\USBnull-r5684.dll
Binding FW: C:\Games\EmuCR-Pcsx2-r5427\r5725\pcsx2-5725-windows-x86\plugins
\FWnull-r5684.dll
(GameDB) 9645 games on record (loaded in 115ms)
Binding DEV9: C:\Games\EmuCR-Pcsx2-r5427\r5725\pcsx2-5725-windows-x86\plugins
\DEV9null-r5684.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: D:\Games\ISOs\Yakuza.iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2181728 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Games\EmuCR-Pcsx2-r5427\memcards\Mcd001.ps2
McdSlot 1: C:\Games\EmuCR-Pcsx2-r5427\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.00(14/06/2004) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_541.71;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SLES_541.71;1) Game CRC = 0xD3F182A3, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_541.71;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break
vif1 force break

Any suggestions?
Reply

Sponsored links

#2
does the vif1 force break only start when the screen goes black or does that happen consistently throughout the game?

also have you tried the 1.0.0 release version to see if it is any different?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
The vif1 force break only begins once I hit a black screen.

I've rolled back to the official 1.0.0 release and played for an hour. It seems to be running pretty smoothly thus far with nothing to report. Will see how it fares.
Reply
#4
cool, any chance you could check a few svn revisions and see if you can find where it appeared?

If you go here: http://buildbot.orphis.net/pcsx2/ start with revision 5500ish. if that one is broken try ones between 5200 and 5500 (this was around the time of release), if its newer, try a couple of hundred up and so on, until you find a rough range, then try ones in the middle of the range you just tried till you find where it broke, this would be a great help!

Thanks Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Your emulog shows it's from EmuCR. Why not go to the official SVN versions page.

http://pcsx2.net/download/development/svn.html
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#6
[/quote]

(09-09-2013, 03:00 PM)DaTankAC Wrote: Your emulog shows it's from EmuCR. Why not go to the official SVN versions page.

http://pcsx2.net/download/development/svn.html
I must've originally grab the latest SVN build from EmuCR when I built my new pc. I got a stack of subdirectories with more recent pcsx2 builds from Orphis' automatic build page each time i come back to play a new game.

(09-09-2013, 02:20 PM)refraction Wrote: cool, any chance you could check a few svn revisions and see if you can find where it appeared?

If you go here: http://buildbot.orphis.net/pcsx2/ start with revision 5500ish. if that one is broken try ones between 5200 and 5500 (this was around the time of release), if its newer, try a couple of hundred up and so on, until you find a rough range, then try ones in the middle of the range you just tried till you find where it broke, this would be a great help!

Thanks Smile
Yea no problem. I understand the description is rather vague to figure out what could be triggering the issue. I'll run through the game through several builds trying to replicate the issue.
Reply




Users browsing this thread: 1 Guest(s)