Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yet another FFXII thread.
#1
Hi all!
I've been lurking the forums now for the past few days trying to configure pcsx2/playground (and trying different svn) but i can't seem to get a decent framerate in FFXII.

So the framerate drops when there's alot of npcs (in town for example) and during ingame cutscenes. It goes from full 60 fps to about 25-38 fps, depending on how many npcs there's on the screen.
The only thing that seems to help is running in windowed mode with native resolution on.
I've tried changing settings in advanced, different speedhacks and so.
I get a more stable framerate through ZeroGS but it looks horrible.

Before i spend more time with "trial and error"-searching i wanted to check and see if there's anyone that can get a stable 50-60 fps ingame everywhere, or if these framerate drops is showing for everyone in similar places in game/settings in the emulator.



Using:
PCSX2-r528.exe on vanilla playground installation.
GSDX 890 SSSE3 0.1.14
SPU2ghz playground 1.9.0 (the squeaking noise is hilarious)

Computer Spec:
CPU: E8500 3,16ghz @ 4,1ghz
MOBO: gigabyte X48-DS4
GPU: ATI Radeon 4870X2 (2gb DDR5)
RAM: 4gb OCZ 8500 (2x2gb kit) @ 5-5-5-15
Display resolution: 1680*1050.
Onboard realtek soundcard.

If anyone happens to have similar or somewhat less powerful setup than me, and runs a different revision or perhaps have found a particular settings that allows for 50-60 fps overall gameplay i would be very glad if you could share your information.
If its not really possible then i won't bother with trying to tweak it/trying other revisions until it's fully stable and just play my other ps2 games i have.

Thanks!
Reply

Sponsored links

#2
the game is a bit CPU intensive, it'll happen.
Reply
#3
your computer is really,really good,and the mobo is more-likely known to be a P45 classification.

*try change your GSdx to 0.1.7
*and in the pcsx2 laucher select Confg-->advanced
select clamp mode to None in EE and VU
FtZ and DrZ checked in EE and VU
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#4
I get a pretty consistent 50-60 fps with similar hardware. I also use SPU2ghz playground for sound, I've gotten so used to the squeaking noise by now. The other sound plugin (ZeroSPU2) gets rid of the squeaking noise, but the sound is louder and harsher so I don't use it.

Under CPU, I turned on EERec, VU0Rec, VU1Rec, and MTGS. Framerate is set to "Limit" - I'd rather have the game slow down sometimes rather than skip frames.

I'm attaching screenshots for my speedhacks and advanced settings.

I don't use "Disable VU Overflow Checks" because that will cause my game to hang when I zone from the Bazaar in Rabanastre to the North End.

I don't use "EE/IOP Sync Hack x3" because that prevents me from saving games.

I haven't fooled with the advanced options yet, but I do know that if I change some of the options the menu and dialogue text vanishes.

   

   
Reply
#5
GSDX dislikes ATI cards in some scenarios.
Try using the GSDX SSE4, DirectX10 Mode. Try to enable Denormals are Zero, try VU skipping ( 2-2 settings ), native resolution.

I have a E8400@3.0-3.6GHz, 8800GT and it's running FFXII ( PAL ) at maximum ( 50 ) fps in almost any situation. Last time I tested was with r528, newest GSDX, 1024x1024 internal, no VSYNC, no speedhacks, Denormals are Zero.
Reading the OFFICAL GUIDE can answer 90% of your newbie questions
SEARCHING the forums can answer 90% of your advanced questions.
Reply
#6
(02-23-2009, 01:26 AM)VeaaC Wrote: GSDX dislikes ATI cards in some scenarios.

i thought ATI is good in D3D while Nvidia on both D3D/OGL..o_O
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#7
(02-23-2009, 12:48 AM)accela Wrote: Computer Spec:
CPU: E8500 3,16ghz @ 4,1ghz
MOBO: gigabyte X48-DS4
GPU: ATI Radeon 4870X2 (2gb DDR5)
RAM: 4gb OCZ 8500 (2x2gb kit) @ 5-5-5-15
Display resolution: 1680*1050.
Onboard realtek soundcard.

I highlighted your problem. GSdx + ATI Video + FFXII == SLOW. You'll probably get better framerates using software mode. Sad

There are no known fixes for this bottleneck at this time, besides the annoying (and obvious) option of buying an nvidia card. Sorry.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#8
Try to disable croosfire mode when you will play pcsx2 emulation. I think jaks comment is not entirely true, become slow?? I dont get it.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
Reply
#9
Allright, thanks for the tips guys. I figured it might've been something with it being an ATI card, because thats basicly the only thing that differs from other threads regarding FFXII.
I will try software mode and see if its playable.
zerogs as said was working fine, but it looked horrible except when i turn AA on at 8x but the performance hit is worse than using gsdx.

Can't run it in DX10 because then i have to reformat to vista and the atidrivers for vista is fubar (not clocking up the card correctly when in 3dmode and various other things).

Not sure if i can turn off crossfire mode since it's a single card with two gpus. I'm gonna look it up and see if its possible and if i notice any increase in performance.
I do have a 8800GTS 320mb somewhere and if all else fails i could try plug it in and see if there's any increase.

Thanks for the help guys!

[[EDIT]]
@tallbender: No it's not P45, its X48 chipset.
Reply
#10
You should do just fine with the 8800GTS and your C2D..

A friend of mine had also problems with his framerate, he also used an ATI card. I lend him my old 9600GT and he had always 55-60~ f/s with his E6600 @ 3,4 GHz.


I'm running constant 60+ f/s with my rig.

E7200 @ 3,825Ghz
nVidia 9800GTX @ GTX+
3GB GEIL BlackDragon+Ballistix @ 1000MHz
... rest is irrelevant I think.

We used nearly the same configs.
Reply




Users browsing this thread: 1 Guest(s)