Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
agressive-CRC hack doesn't save (GSdx.ini)
#1
I use PCSX2 1.3.1-20150720231559. Whether I choose openGL (hardware) or DX11 (hardware), the agressive-CRC hack isn't saved when I select it. I also use PCSX2Bonus, which also doesn't save the hack when selecting it. All other settings/hack are saved perfectly fine when selecting them.

When I check GSdx.ini, the settings isn't mentioned.. that's weird right? Can I manually add it & if so - how?

Thanks? Smile

By the way, this is my GSdx.ini file:

[Settings]
ShadeBoost_Contrast=60
ShadeBoost_Brightness=50
ShadeBoost_Saturation=55
UserHacks_MSAA=0
crc_hack_level=2
UserHacks_AlphaHack=0
UserHacks_HalfPixelOffset=1
UserHacks_SpriteHack=0
UserHacks_SkipDraw=0
UserHacks_WildHack=0
UserHacks_AlphaStencil=0
UserHacks_round_sprite_offset=2
Userhacks_align_sprite_X=1
UserHacks_TCOffset=0
Adapter=10DE:1004:84691043:A1
Renderer=12
Interlace=7
AspectRatio=0
upscale_multiplier=5
MaxAnisotropy=16
filter=2
paltex=0
logz=1
fba=1
aa1=0
nativeres=0
resx=1024
resy=1024
extrathreads=0
AnisotropicFiltering=1
accurate_blend=1
accurate_date=1
accurate_colclip=1
texture_cache_depth=0
ShadeBoost=0
Fxaa=1
shaderfx=0
shaderfx_conf=shaders/GSdx_FX_Settings.ini
shaderfx_glsl=shaders/GSdx.fx
UserHacks=1
accurate_fbmask=0
Reply

Sponsored links

#2
the option was (must be?) removed. Hack is controlled with this new parameter
Quote: crc_hack_level=2
Reply
#3
(07-22-2015, 08:49 AM)gregory Wrote: the option was (must be?) removed. Hack is controlled with this new parameter

Okay, but when I delete the ini file altogether and open PCSX2 to let it generate a new one - nothing changes.. I still can't save the agressive-CRC hack and when I open GSdx.ini "crc_hack_level=2" is still in it..
Reply
#4
Aggressive-CRC is still present in the windows version (at least in mine - from a couple of days).

Just ignore this option. Probably it points to nowhere.
(The same option is now in the crc combobox. That's all you need.)
Reply
#5
So you're suggesting I choose "Full" instead of "partial" CRC hacks, dispite of "partial" being recommended for OpenGL?

It's still weird I can select the hack, but it's not being saved right..?

Is it enabled automatically when I select "full"?

I mainly want to use it for Shadow of the Colussus, which has the "bloom fx problem" without the hack.
Reply
#6
Option need to be removed. The button is useless. Everything is controlled by a single combo box.

Partial is recommended as the best default setting for openGL. Full will likely remove some effects that openGL can emulate, however it might increases the performance. In your case, you can directly use the last level (aggressive) to disable the bloom effect on SotC.
Reply
#7
Thanks for the info Gregory! I will give it a go later today.

Are there any other hacks which are really only controlled via the box (full/partial/aggressive)? Of is it just the aggressive-CRC hack?

And to bad the "aggressive" is necessary for Shadow of the Colossus - I bet there are quite a few FX disabled because of it.
Reply
#8
The drop down just replaced the "disable crc hack" and "aggressive CRC" and added some newer options to allow some other effects through now they are being handled by OpenGL (and maybe DX in the future) Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
Yes a couple of hack were dropped in openGL. You can enable them but they won't have any impact.

Future openGL code might work better with the bloom effect for small upscaling. However you can also increase the upscaling to reduce the bloom effect (3x/4x).
Reply
#10
Thanks a lot guys, great info!

@Gregory: I play SotC @3x IR. Any higher and framerate doesn't seem as smooth. But then again, I'm really trying to figure out the best combination of framelimit/vsync for this & I'm really sensitive to framerate fluctuations. Right now I use an external framelimiter @60fps (rivatuner) and I have disabled vsync + the framelimiter in PCSX2. Enabling vsync seems to produce more stuttering and I need the framelimiter off in PCSX2 to reach a steady 30fps. PCSX2 says it's @60fps, but that's not the case - it's definitely 30fps. Which is a real improvement compared to the 20-ish framerate of the PS2.
Reply




Users browsing this thread: 1 Guest(s)