Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
best/"normal" compression with pcsx2 recorder?
#1
what's the best/most used compression method when recording with pcsx2? and should i use DMO, DS or VfW? like, what gives good/best possible quality? i don't want a 3-4min recording to be like several 100mb (HD-quality), but just "normal" quality without too many visible pixels...

i assume the ffdshow-option (MPEG-2 encoder with one pass mode) is the way to go, yes?

Reply

Sponsored links

#2
i'm using H.264 format using this format can now only be about 30~40MB in a 3~4 min recording good for easy upload in youtube.


Attached Files Thumbnail(s)
   

.xml   youtubeHD.xml (Size: 1,67 KB / Downloads: 197)
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
ok. but somehow the h.264 seems to slow down game during the recording process and it also gives about +0.5x speed-up for the actual recorded video instead of normal speed when i view the file in a media player. that doesn't happen when i use the XviD MPEG-4 codec compression method. there the game during the recording process is slowed down a bit, but the actual recorded video is in normal speed. but of course the size of the file gets like 100mb+ (for 4-5 mins video) depending on how good quality you want.

maybe my settings for H.264 are wrong?? should i use different "FourCC", perhaps?? see below for a screenshot of my current settings as well as my options for compression in pcsx2.

also, if i want to include audio with the recording, i must use 2 pass-method, yes?


Attached Files Thumbnail(s)
           
Reply
#4
Encoding a video using h264 is very CPU-intensive; that's definitely going to slow down the emulation. I'd go for a codec that isn't too demanding when recording gameplay (I personally use HuffYUV or Lagarith, but you'll need to have plenty of disk space since those are both lossless). For me, it's usually 'record video now, worry about quality later'.

Changing the FourCC (on its own) doesn't affect the speed at all.

To include audio in the recording, you will need to re-encode the video and the audio together outside of pcsx2... (use VirtualDub, or something similar). It does not need to be 2-pass; 2-pass encoding concerns only the video, not audio.
Reply
#5
so in order to NOT lose any video quality i should record the video using "uncompressed" and then use virtualdub after the recording to compress the recorded video to xvid and audio to mp3, yes? that would give best possible quality, yes? but... i tried that and my pcsx2 just crashes/closes when/if i choose "uncompressed". so then patrickdinh's method is the best way to record, or??

patrickdinh: i can record with HuffYUV codec if i choose "(VfW)ffdshow" compression method and then choose "HuffYUV" from the encoding list... is that what you meant, yes??

EDIT: i've been recording the games in normal speed for a while now, but i notice now that whenever i try to record, whether i choose ffdshow (with HuffYUV-encoding) or XviD MPEG-4 compression method, the recording process is slow like it should be, but when i watch the recorded video itself, the video is running TOO fast... why?! im trying to run a PAL-game, and in XviD MPEG-4 compression you can choose either 25 FPS (PAL) or 50 FPS (PAL HD) in "calc.."-options... whatever i choose, it doesn't give me normal speed for the recorded video. any ideas on this one??
Reply
#6
Instead of recording in pcsx2 with "uncompressed", using a lossess codec (like HuffYUV) will compress the video without any quality loss.

If your recording is playing back too fast, try to see if you can set it to the right framerate using VirtualDub. (Just a thought... did you change your GS framelimiter settings?)
Reply
#7
so you are saying that i should record it with an external recording device (using HuffYUV codec)..? what sort of recording device instead of the built-in pcsx2 recorder should i be using then you suggest??

not really sure WHY the playing back is being TOO fast... haven't changed a thing in my GS framelimiter, really. and where do i change that framelimiter anyway? you're talking about the frame limiter in the CPU-section?
Reply
#8
(11-29-2010, 10:37 AM)minstreless Wrote: so you are saying that i should record it with an external recording device (using HuffYUV codec)..? what sort of recording device instead of the built-in pcsx2 recorder should i be using then you suggest??

Not what I meant; I was only saying that there isn't really much of a good reason to record your videos uncompressed, in any case... especially for long recordings (massive disk usage).

(And given my system specs, I wouldn't even think of using anything else but the built-in recorder.)

Also, have you tried using VirtualDub to adjust the framerate of your recording so that it isn't playing too fast? It's possible that the video was saved with the wrong framerate.

(11-29-2010, 10:37 AM)minstreless Wrote: you're talking about the frame limiter in the CPU-section?

Yes... (seems you're using pcsx2 0.9.6)
Reply
#9
i see. i'll adjust the framerate/speed of my recorded .avi with virtualdub. thanks.

well, i just encountered another issue... whatever codec i choose and start recording, i get both the .avi and the .wav in the same folder, but the .wav is like in super small size AND while the video is like 4mins long, the .wav is like 1min long or something like that. most of the audio has...well...vanished, basically. when i listen to the .wav-file in i.e winamp, the audio doesn't sort of match and it's too short. why's that? how do i get this to record the audio properly? im using GSdx for cpu/gfx and SPU2-X for audio. EDIT: i just noticed that when i stop the recording process by pressing F12 again and then again, it "resets" the size of the recording.wav to 0 kB! why? EDIT2: solved this problem by just pressing F12 once, not twice. doh! my bad for this. =/

and yep, im still using 0.96 as it works best for me for the moment.
Reply
#10
(12-03-2010, 01:19 AM)minstreless Wrote: EDIT: i just noticed that when i stop the recording process by pressing F12 again and then again, it "resets" the size of the recording.wav to 0 kB! why?


Probably cause it starts recording again and since it doesn't ask for the file to write it just overwrites the one that's there.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)