Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
cant compile today's svn 23.12.13
#1
tried to compile newest svn under a 32bit chroot ubuntu 13.10 (i'am using xubuntu 13.10 64bit)

its not the first time i compiled pcsx2 i do that every month

it fails with this message

Code:
Scanning dependencies of target zzogl-static
[ 74%] Building CXX object plugins/zzogl-pg/opengl/CMakeFiles/zzogl-static.dir/GifTransfer.cpp.o
In file included from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg/opengl/HostMemory.h:23:0,
                 from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg/opengl/GS.h:28,
                 from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg/opengl/GifTransfer.cpp:20:
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg/opengl/GLWin.h:49:25: error: expected ')' before '_PFNSWAPINTERVAL'
typedef void (APIENTRYP _PFNSWAPINTERVAL)(int);
                         ^
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg/opengl/GLWin.h:72:3: error: '_PFNSWAPINTERVAL' does not name a type
   _PFNSWAPINTERVAL swapinterval;
   ^
make[2]: *** [plugins/zzogl-pg/opengl/CMakeFiles/zzogl-static.dir/GifTransfer.cpp.o] Error 1
make[1]: *** [plugins/zzogl-pg/opengl/CMakeFiles/zzogl-static.dir/all] Error 2
make: *** [all] Error 2
Reply

Sponsored links

#2
The good news is that you're not the only one Wink. The bad new is that it work nicely on my computer Sad

Can you give me your glew, gcc, mesa version?

Edit: gcc -v
Reply
#3
gcc -v
Code:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/i686-linux-gnu/4.8/lto-wrapper
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.8.1-10ubuntu9' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-i386/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-i386 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-i386 --with-arch-directory=i386 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-targets=all --enable-multiarch --disable-werror --with-arch-32=i686 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu9)

glew is 1.8.0
mesa is 10.0.0
using nvidia driver 331.20 if that helps
Reply
#4
ok thanks. the root cause is mesa 10. I got the same issue.
Reply
#5
Please retry latest svn. Thanks
Reply
#6
does not work there's a new error

Code:
[ 90%] Building CXX object plugins/zzogl-pg-cg/opengl/CMakeFiles/zzogl-cg-static.dir/GSmain.cpp.o
In file included from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/targets.h:28:0,
                 from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/ZZoglFlushHack.h:30,
                 from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp:24:
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/ZZGl.h:103:23: error: expected ')' before '*' token
extern void (APIENTRY *zgsBlendEquationSeparateEXT)(GLenum, GLenum);
                       ^
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/ZZGl.h:104:23: error: expected ')' before '*' token
extern void (APIENTRY *zgsBlendFuncSeparateEXT)(GLenum, GLenum, GLenum, GLenum);
                       ^
In file included from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/Util.h:58:0,
                 from /home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp:20:
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp: In function 'void GSsetGameCRC(int, int)':
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/CRC.h:405:65: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
#define GAME_INFO_INDEX (sizeof(crc_game_list)/sizeof(Game_Info))
                                                                 ^
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp:187:23: note: in expansion of macro 'GAME_INFO_INDEX'
   for (int i = 0; i < GAME_INFO_INDEX; i++)
                       ^
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp:189:32: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
    if (crc_game_list[i].crc == crc)
                                ^
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp: In function 'void GSReplay(char*)':
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp:754:29: warning: ordered comparison of pointer with integer zero [-Wextra]
      case 0: _GSgifTransfer<0>(&p->buff[0], p->real_size); break;
                             ^
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp:754:57: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits]
      case 0: _GSgifTransfer<0>(&p->buff[0], p->real_size); break;
                                                         ^
/home/robert/Downloads/pcsx2-read-only/plugins/zzogl-pg-cg/opengl/GSmain.cpp:665:8: warning: unused variable 'start' [-Wunused-variable]
   long start = ftell(fp);
        ^
make[2]: *** [plugins/zzogl-pg-cg/opengl/CMakeFiles/zzogl-cg-static.dir/GSmain.cpp.o] Error 1
make[1]: *** [plugins/zzogl-pg-cg/opengl/CMakeFiles/zzogl-cg-static.dir/all] Error 2
make: *** [all] Error 2
Reply
#7
Ok. I would fix it but you can safely remove this old version of the plugin (rm -fr plugins/zzogl-pg-cg)

Edit: must be fixed now
Reply
#8
its working now, thanks
Reply




Users browsing this thread: 1 Guest(s)