Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
constantly speeding up and slowing down...
#1
making audio quite awkward, and I don't really want to Async Mix it :/

It shouldn't be that my computer is too slow, if I turn of frame limit it'll run freakishly fast the whole time.
In a FMV I used "use synchronized MTGS" and that fixed the problem, but in gameplay that makes it much too slow.
Any ideas? Thanks in advance~

using pcsx2-r4600

Lenovo Win7 PC
Intel Core i7-2360QM
CPU@2GHz
8GB RAM
64bit OS
Reply

Sponsored links

#2
try turning on MTVU in speedhacks. though 2GHz is weak for pcsx2. a 2GHz i7 may be fine for PC games, but in regards to emulation, 2GHz really isnt enough. Using MTVU you should get a bit of a speedup, as well as trying some of the other speedhacks.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#3
(08-20-2011, 04:57 PM)Dante3hs Wrote: try turning on MTVU in speedhacks. though 2GHz is weak for pcsx2. a 2GHz i7 may be fine for PC games, but in regards to emulation, 2GHz really isnt enough. Using MTVU you should get a bit of a speedup, as well as trying some of the other speedhacks.

I disagree strongly. It's a sandy bridge quad core and it turbos to 2.6 GHZ even when all 4 cores are active.

Rezard has a 2500k@2.5ghz on the CPU benchmark:
http://forums.pcsx2.net/Thread-CPU-Bench...d-on-FFX-2

I would expect this CPU to perform very similarly to that, which is very similar to Core 2 procs @ 3ghz+, and Phenoms at 3.3ghz+, both of which are very capable.

My best guess is it's some sort of laptop power saving feature. Make sure that you're plugged in and all power saving options are to "performance" or "max".
Reply
#4
im generally too lazy to google the specifics of every CPU people post, and i dont know what architecture a CPU is just by looking at the model, so i usually post with generalised info from an as far as im aware pov.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#5
intel Turbo is the problem.

its fine with pcsx2 running un capped because it forces an adequate load to maintain the cpu's turbo value.
Reply
#6
(08-20-2011, 05:08 PM)natt Wrote: My best guess is it's some sort of laptop power saving feature. Make sure that you're plugged in and all power saving options are to "performance" or "max".

It is set to high performance and pcsx2 is set to high priority from task manager...
(08-20-2011, 05:38 PM)Squall Leonhart Wrote: intel Turbo is the problem.

its fine with pcsx2 running un capped because it forces an adequate load to maintain the cpu's turbo value.
so is there anything i can do about it or am I just stuck with it?
(Sorry, I'm not super tech savvy)
Reply
#7
(08-20-2011, 05:38 PM)Squall Leonhart Wrote: intel Turbo is the problem.

its fine with pcsx2 running un capped because it forces an adequate load to maintain the cpu's turbo value.

Would running a background process that pegs 1 core fix it?
Reply
#8
That hasn't worked since nehalem.

Each core can increase its clocks and turbo individually as needed,

It might help to run

Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\0cc5b647-c1df-4637-891a-dec35c318583]
"Attributes"=dword:00000000

and then set the newly exposed "Processor Performance Core parking Min cores" to 100% from 10% in the advanced power profile settings to prevent cores from entering the C6 state.
Reply




Users browsing this thread: 2 Guest(s)