Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
controler problem
#1
Hey Im having trouble with lilypad 0.10, my controller has same nuber of buttons as a ps2/3 controller, but when I test the controller it says triangle is button zero. I have no button zero, just 1 through 16 including d pad. and its screwing up my games. its like square is cross, cross is circle, circle is triangle, triangle is nothing. I used search but found nothing, please help.
Reply

Sponsored links

#2
programing ALWAYS starts with 0 the button 1 you have is button 0 according to the PC
Reply
#3
(09-01-2010, 07:52 PM)Saiki Wrote: programing ALWAYS starts with 0 the button 1 you have is button 0 according to the PC

So is there no fix?
Reply
#4
that's completely intentional..
Reply
#5
I see... So the problems with my controller? Is there such a controller with a 0 button?
Reply
#6
Button 1 in your controller will be mapped as 0 then button 2 as 1, 3 as 2, 16 as 15 etc... as Saiki said it's normal and not a big deal... unless you're having a mayor problem because of it you're not telling us? After you set the buttons you shouldn't have/need to see the mapped buttons again anyway.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
(09-02-2010, 10:11 PM)Shadow Lady Wrote: Button 1 in your controller will be mapped as 0 then button 2 as 1, 3 as 2, 16 as 15 etc... as Saiki said it's normal and not a big deal... unless you're having a mayor problem because of it you're not telling us? After you set the buttons you shouldn't have/need to see the mapped buttons again anyway.

Not a big deal? So your saying everyone here is playing with a controller that has L1 as square, square as cross, cross as circle, circle as triangle, and triangle as inoperable? There's nothing wrong with my controller. It just looks like what Evers assigned to 0, doesn't work.
Reply
#8
You should manually reassign each button. Click on each button, and then press the buttons on the controller to map the correct buttons to correct actions. Whatever it shows, 15,16 or FF it has no real difference to you if you are not looking at the source code.
i7 @ 3.2Ghz /w Noctua
6GB Dominator 1600Mhz
5770 Vapor-X
1.5 TB Raid 5 /w 3ware 9650SE

Reply
#9
Ah, so you did have a problem where no matter what you set it comes with the wrong/unwanted output. You were not saying that correctly Tongue2

Try a different controller plugin, try enabling/disabling the game device APIs in lilypad controller, try updating the drivers for your gamepad controller.

What game controller is it BTW? Can you show us a screenshot of the button and settings in Lilypad controller plugin?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
(09-02-2010, 11:11 PM)Shadow Lady Wrote: Ah, so you did have a problem where no matter what you set it comes with the wrong/unwanted output. You were not saying that correctly Tongue2

Try a different controller plugin, try enabling/disabling the game device APIs in lilypad controller, try updating the drivers for your gamepad controller.

What game controller is it BTW? Can you show us a screenshot of the button and settings in Lilypad controller plugin?

ok ill try. How do I do it?
(09-02-2010, 11:11 PM)Shadow Lady Wrote: Ah, so you did have a problem where no matter what you set it comes with the wrong/unwanted output. You were not saying that correctly Tongue2

Try a different controller plugin, try enabling/disabling the game device APIs in lilypad controller, try updating the drivers for your gamepad controller.

What game controller is it BTW? Can you show us a screenshot of the button and settings in Lilypad controller plugin?

oh, im sorry i forgot.Ohmy its a Philips SGC2909BB. and the drivers are updated.
Reply




Users browsing this thread: 1 Guest(s)