Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
digital devil saga performance
#1
i'm trying to play Digital Devil Saga, but i can't because of the low fps i get. my computer is not that great, but i'm able to play other games easily, without having to worry about it being slow.

First of all, if i use the graphic plugin with None in the interlacing mode, the image shakes, which forces me to choose Blend bff (tff blurs the image too much), and that makes me lose 1/2 of my fps. (with this option, i get around 20 fps, but it may increase or decrease a bit, depending on where i am)

The other problem is more of a graphical problem, and it's annoying, since it makes the image hard to see. When i get in a fight, the image is normal, but after that fight, i get the image of when i got in the fight, and it overlaps the current image... i can see what i'm doing, but with some difficulty, and it makes the game hard to enjoy.
i even turned off the sound in the plugin, since it isn't very good, hoping to get a little speedup, but it doesn't make a big difference...any ideas on how can i get a little speedup on it, and/or solve the problem of the shaking image without having to use the blend interlacing mode?
i'll give informations about my config and my pc if needed
Reply

Sponsored links

#2
You're using an outdated version of PCSX2 and plugins.
Try the 0.9.7 beta from here:
http://pcsx2.net/downloads.php?p=publicbeta
Reply
#3
tried it now, it solves the image overlap after battle but not the shaking screen and consequently, the low fps count :\
Reply
#4
Set the interlacing to mode 6. It doesn't affect the game speed at all.
Reply
#5
(10-24-2010, 06:15 PM)rama Wrote: Set the interlacing to mode 6. It doesn't affect the game speed at all.

it's the mode i'm using, won't it half my fps count?
if not, there isn't a way to increase the performance, is there?
Reply
#6
(10-24-2010, 06:47 PM)clovias Wrote:
(10-24-2010, 06:15 PM)rama Wrote: Set the interlacing to mode 6. It doesn't affect the game speed at all.

it's the mode i'm using, won't it half my fps count?
if not, there isn't a way to increase the performance, is there?

It will half the number of frames that are presented to the screen but you will still be getting the same game speed as the same amount of frames are being rendered internally. Mode 6 just causes each pair of fields to be blended into one frame before presenting.
Specs in Profile
Reply
#7
so, any idea on how to improve the speed?
Reply
#8
PC specs? PCSX2 settings? Plugin settings? What do the EE/GS % numbers say when you get the slowdowns?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
(10-25-2010, 06:34 AM)Shadow Lady Wrote: PC specs? PCSX2 settings? Plugin settings? What do the EE/GS % numbers say when you get the slowdowns?

from what i saw in other posts, i find it strange that my pc can even run the games, but here it is:

OS: Windows Vista x32 sp2
CPU: Intel Pentium Dual T3200 @2.00GHz
RAM: 3Gb
Graphics: ATI Mobility Radeon HD 3470 (not sure what's the memory of this one)

as for pcsx2, i'm running the latest 0.9.7 beta (r3876)

Emulation Settings:
-EE/IOP
EmotionEngine set to Recompiler
IOP set to Recompiler
EE/FPU recompiler options set to chop/zero in round mode and normal in clamping mode
flush to zero and denormals are zero checked
-VUs
both VU0 and VU1 set to microVU Recompiler
round mode set to chop/zero and clamping mode set to normal
flush to zero and denormals are zero checked
-GS
Frame Skipping disabled
Framelimiting enabled, with base framerate adjust in 100%, slow motion to 50% and turbo to 200%
-Speedhacks
EE Cyclerate set at 2
VU Cycle Stealing at 1
INTC Spin Detection enabled
Wait Loop Detection enabled
mVU Flag Hack enabled

PLUGINS
-graphical: GDSx 3693 SSE3
renderer set to direct3d10 (hardware)
interlacing mode at blend bff
resolution set to native

as for sound, i've disabled it, since it most of the times sounds pretty bad, and this way i could get a speedup

not sure if i game too much more information, and i don't really believe it's possible to improve the game with this pc, but i hope it can be done

ingame, the EE is in the 90%s, and GS is around 50%
Reply
#10
Try changing the clamps to 'none', set the VUs to superVU, try a higher setting of VU cycle stealing (but make sure it actually makes the game faster) and... that's about it... this will lower the compatibility for most games but should be fine with this one and you're right you have a slow CPU so there's not much more you can do.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)