Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
emulator constantly crashing while playing final fantasy x
#1
hi,

a few months ago i bought a new laptop. it's a hp pavilion dv6, 8gb ram, windows 7 64 bit, dual vga card which is mobile intel and radeon hd 6770m

i installed ver 0.9.8, i didn't modify any settings and left the default ones then played final fantasy x. i reached the very end. in a few months i had finished the main storyline and started on the sidequests. yesterday in the morning i was capturing the monsters in gagazet caves. i then pressed esc to pause the emulator and closed my laptop. i resumed the emulator in the evening and that's when my problems started

shortly after i started pcsx2 crashed, i restarted the emulator, loaded my saved game and it crashed again after a few minutes. it crashes if i am in normal or turbo mode and windowed or full screen. i restarted the emulator a few times and the same thing happened. i restarted my laptop. that usually solves any problems i have with the emulator. this time it didn't. i then removed pcsx2 and reinstalled it. i started the game and watched the intro. i hoped that would solve the problem but unfortunately it didn't. it crashed as tidus was talking to his fans. i then started messing about by selecting different display plugins and different directx modes. nothing helped. i changed the resolution of the game and the resolution of windows. didn't work. i set the emulator to use my ati card. it didn't help. i also tried installing pcsx2 ver 0.99. it also crashed. once the the emulator crashed and the other time it caused windows to crash with a bluescreen. i then went back to ver 0.98 and disabled enable auto game fixes which was loading IpuWaitHack. luckily it stopped crashing after a few minutes. however other things happened in windows. windows desktop manager crashed and the screen refreshed a few times. the emulator continued running. i then caught the rest of the monsters in gagazet, defeated belgemine and got the moon sigil and powered nirvana, then paused the emulator. i played in windowed mode and in normal mode

why was it crashing? is the fault with windows or the emulator? i am worried it will crash again. what is causing the crash? i changed nothing in the windows during the time that i didn't play the game in between. during that time the emulator changed from working nicely to constantly crashing

attached is a pic of the emulator when it crashed. i had made more pics but lost them due to windows crashing. before the only warning messages that i used to receive in the log was "Totally mismatched window handles on OverrideWndProc!" and the emulator would crash if it appeared many times in a row. i just restarted and it would work fine. now i started receiving new messages when it was constantly crashing. in the pic one such new message is shown. another warning i got had the word addr in it and some number in hexadecimal after it and it said miss in the end. also attached is the current state of my plugins and display. all the rest of the settings are unchanged

has anyone experienced my problems? if yes what is the solution? also what settings should i change in the core gs settings for final fantasy x to work fine

   
   
   

Sponsored links

#2
Did you try updating your display drivers,
and switching between your igp and gpu midgame, may cause crashes in pcsx2
Also you can use DX11 mode, which is usually more compatible(less graphic glitches) and prettier O:
[Image: 8rg00e-4.png]
#3
(12-04-2011, 05:46 AM)thatwasonce Wrote: Did you try updating your display drivers,
and switching between your igp and gpu midgame, may cause crashes in pcsx2
Also you can use DX11 mode, which is usually more compatible(less graphic glitches) and prettier O:

that didn't help me. i was running it under my igp the whole time until it started crashing. now i switched to the gpu. it also crashed. it's very weird. i did a complete uninstall and reinstalled and tried the game from the beginning it still crashed. after i switched off the auto game fix it stopped crashing for a bit, until now. i tried switching to turbo mode and my laptop crashed with a blue screen :-(
#4
maybe you put some unstable cheats try disable it
or too much speedhacks minimize it or set preset slider to LV-1-Safe
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
#5
(12-04-2011, 10:28 AM)tallbender Wrote: maybe you put some unstable cheats try disable it
or too much speedhacks minimize it or set preset slider to LV-1-Safe

they are disabled. i updated my video drivers but it didn't help

btw what does the screen below mean? i guess the error messages that appear are causing my emulator to crash
   

if i can't find a solution then i want to format my laptop. it's powerful yes, but i have disliked the windows i have. it's causing me problems. i will change it. hopefully a fresh windows will solve all my problems
#6
I was wondering... Apparently, your FFX image is 3.55 big while mine is around 4.0 Big.
I know you have NTSC and I have PAL-FR, but could it be you misdumped your Image ?
Did you try with the physical DVD directly in your reader to see if the problem is still here ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#7
His version is NTSC-U, SLUS 20312. I have the exact version and its size is 4.19 GiB (4,508,221,440 bytes). PAL version is usually a little bigger.

What is the MD5 checksum of your FFX iso, cns00?
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
#8
That screen:
It shows TLB Miss probably due to cheats gone wrong...
#9
i made the game work :-)

to answer your questions, i am unsure of the mds checksum. i got the game from demonoid from the torrent the ultimate ps2 collection

and no. i am not using cheats. when that warning message came at the same time windows said that there was an error in my display driver and it recovered

the fault was with windows. the laptop came with win 7 home premium 64 bit. it was too flashy and colorful. i only enjoyed my laptop for one month until problems started happening and win used to freeze up. i endured it until now when pcsx2 kept crashing and 4 times it caused windows to freeze with the blue screen. when the blue screen appears often the fault is with windows. i don't know why this happened. i guess it's because of the windows updates. some are ok while others cause problems

so i had my drive formatted and win 7 enterprise was placed instead. 32 bit windows was placed. it's the same as the 64bit one, however i can't use my full memory. i have 8gb ram and i am only using 2.54gb of it. when i tested the game ran smoothly. i guess that is because my processor is powerful. i also have installed just cause 2 on my laptop. it ran smoothly

i guess i want to keep the 32 bit one installed for now. performance-wise things are ok. when the processor is powerful a high memory is just a decoaration. should i face any performance problems i will format again and put the 64 bit one. am i doing the right thing?
#10
(12-05-2011, 06:23 AM)cns00 Wrote: i made the game work :-)

to answer your questions, i am unsure of the mds checksum. i got the game from demonoid from the torrent the ultimate ps2 collection

and no. i am not using cheats. when that warning message came at the same time windows said that there was an error in my display driver and it recovered

the fault was with windows. the laptop came with win 7 home premium 64 bit. it was too flashy and colorful. i only enjoyed my laptop for one month until problems started happening and win used to freeze up. i endured it until now when pcsx2 kept crashing and 4 times it caused windows to freeze with the blue screen. when the blue screen appears often the fault is with windows. i don't know why this happened. i guess it's because of the windows updates. some are ok while others cause problems

so i had my drive formatted and win 7 enterprise was placed instead. 32 bit windows was placed. it's the same as the 64bit one, however i can't use my full memory. i have 8gb ram and i am only using 2.54gb of it. when i tested the game ran smoothly. i guess that is because my processor is powerful. i also have installed just cause 2 on my laptop. it ran smoothly

i guess i want to keep the 32 bit one installed for now. performance-wise things are ok. when the processor is powerful a high memory is just a decoaration. should i face any performance problems i will format again and put the 64 bit one. am i doing the right thing?

!!!! WARNING !!!!
PIRATE DETECTED !!!
BANHAMMER INCOMING
!!!! WARNING !!!!





Users browsing this thread: 1 Guest(s)