Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
exit from fullscreen?
#1
AngryAngryAngryAngryAngryAngryAngryAngryAngryAngryAngry

[rant]
i'm about to burst, i'm pissed, i can't understand how an application can't be orderer to close, even if it's a bug or bad configuration, how simple inputs can't tell it close or even lose it's focus? i've never in my life have encountered an application that behaves like this...
[/rant]

now seriously, how exactly am i supposed to exit from fullscreen?
i've tried different plugins for input (matching both pads and not), different configurations on lilypad and i've tried every single combination on windows to close or lose focus of and application, the best i could manage was to shutdown my pc...

PCSX2 0.9.5 svn 403 (it happens with others expect with playground that has an option to fully exit)
i think i don't need to tell you my configurations, i'm pretty sure this is something common and there is a configuration somewhere that i missed, so you probably already know what do i have to change... but seriously why exactly there is the need of that option? how exactly limiting every possible way of exiting an application is useful?

0.9.4 does it, 0.9.5 does it and playground does it (with that option turned off) even the base configuration (deletion of the inis) does it... but if you still have the need of my configuration, please do tell me...
E8400 @ 3.2GHz - 8800 GT @ stock - 4GB DDR2 800 [actual: 3.5GB with PAE] - WinXP PRO 32bit SP3
[Image: 133779.png]

Sponsored links

#2
depends on the gfx plugin you use
If I remember well, ZeroGS allows it whereas only a few gsdx versions do.

I may be wrong, though. Everytime i wanna exit, I just press Alt+F4 and/or kill pcsx2 process using CTRL+ALT+DEL
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
If you mean you pressed escape while in fullscreen. The best thing you can do is press ctr+alt+del (well on vista) and it comes up with that screen, and you press cancel and most probably it'll say there was problem with the program and you have to exit.

Or you could always alt+enter before you close the game.
#4
let me explain it better, any keyboard combination doesn't work, at least not for me, i've tried ESC | ALT+CTRL+DEL | ALT+TAB | ALT+F4 | ALT+ESC | CTRL+ESC | WINDOWS+D | SHIFTx5 (Stickykeys) | others ways that have to change programs or return to desktop

every single them don't close it and don't change the application focus, that means i can't see the task manager to kill the process, i don't have ny special program that could interfere with inputs and in fact i recently formated my pc

if the newest playground have an option to exit with ESC my only guess is that this is actually a known "issue"

my first thought was the configuration with lilypad (that ignore keyboard line seems fishy), but this happens even with other pad plugins...


Attached Files Thumbnail(s)
       
E8400 @ 3.2GHz - 8800 GT @ stock - 4GB DDR2 800 [actual: 3.5GB with PAE] - WinXP PRO 32bit SP3
[Image: 133779.png]
#5
and if you press ESC, then ALT+F4 ?

As I said, you 're using gsdx. Which means you can't use ALT+ENTER to switch between windowed/Full screen mode. Try ZeroGs if you want this feature
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#6
(02-04-2009, 10:27 PM)kebrus Wrote: let me explain it better, any keyboard combination doesn't work, at least not for me, i've tried ESC | ALT+CTRL+DEL | ALT+TAB | ALT+F4 | ALT+ESC | CTRL+ESC | WINDOWS+D | SHIFTx5 (Stickykeys) | others ways that have to change programs or return to desktop

every single them don't close it and don't change the application focus, that means i can't see the task manager to kill the process, i don't have ny special program that could interfere with inputs and in fact i recently formated my pc

if the newest playground have an option to exit with ESC my only guess is that this is actually a known "issue"

my first thought was the configuration with lilypad (that ignore keyboard line seems fishy), but this happens even with other pad plugins...
This happens in DX9 mode and is a GSdx bug.
In Playground,simply check Close GS window on Esc under Misc.That should do it
[Image: newsig.jpg]
#7
Quote:As I said, you 're using gsdx. Which means you can't use ALT+ENTER to switch between windowed/Full screen mode. Try ZeroGs if you want this feature

Alt+Enter works fine for me.. I'm using Gsdx plugin.

@kebrus, have you tried Alt+Enter? >_>
[Image: a0iic2.png]
Vista Home Premium 64-bit | E8500 @4.2GHz (526x8) ~1.30V
Gigabyte GA-EP45-UD3P | 4Gb 1066mhz Corsair XMS2
Radeon HD 4850 OC 10% | 1.14TB (640+500gb) WDC
Antec Nine Hundred | Antec Earthwatts 500w
#8
depends on gsdx version, doesn't it ?

Not every version has this feature
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)