Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
extremely slow emulation
#1
i have played 2 games so far. manhunt 2 beta and gta liberty city stories. they both suffer from extreme fps drops. which is odd cuz i have a nice cpu. manhunt was playable at 40fps but gta drops to 30 fps. its like slow mo. my settings are all default except i use dx10. ive tried dx9 and its still slow. i have the 0.9.7 beta. 0.9.6 does this to. i have tried using native resolution but only increases speed a little bit. my specs are as follows:

core 2 duo e8400 @3.6ghz
radeon 4890
4gigs ddr2 800mhz

with these specs i should sure be playing games full speed with default settings. ive tried the zero video plugin to no effect. wat is going on here.
Core2Duo E8400 @3.9GHZ
Radeon 4890
4G DDR2 @869MHZ
Reply

Sponsored links

#2
jus to add i have the latest video drivers. im using bios v2.3 dated from 2008 from the 90000 series ps2s. my cpu is not overheating. please help! i can run wii games with dolphin full speed. HAAAAAAAALP
Core2Duo E8400 @3.9GHZ
Radeon 4890
4G DDR2 @869MHZ
Reply
#3
we can halp if you tell us something about your PCSX2 and plugin configuration, based only on information you provided, probably it just need some speedhacks.

A good starting point is trying the four top boxes ticked and EE cyclerate and VU cycle stealing both one step right... some games might work nicely with VU hack two steps right, the common sense is: the less speedhacks which give playable speed without issues, the better.
Imagination is where we are truly real
Reply
#4
ive tried the speedhacks and that has no effect either. ive tried many different config settings. i use gsdx with dx10 (hardware). the rest is default. the EE and VU settings are default. ive tried gsdx with dx9 and its actually slower. i tried those speedhacks with different ones enabled and it literally made no difference. im stumped.
Core2Duo E8400 @3.9GHZ
Radeon 4890
4G DDR2 @869MHZ
Reply
#5
Try disabling the vertical synch on your catalyst control panel. About the games specifically, maybe someone who played them can give you specifics, I have neither so I can't even test to see how they behave on the emulator.

PS: the FPS values reported are a strong symptom of vertical synch capping the FPS so it can initiate the drawing together with the monitor's refresh.
Make sure the "Wait for Vsync on refresh" is disabled at the "Windows Settings..." too, under the Video GS config.
Imagination is where we are truly real
Reply
#6
i always keep vsync set to "always off" cuz i simply hate it. its also disabled under gs window. i just tried frame skipping and it had no effect. ive seen youtube videos of ppl playing gta on it and it runs fine. well im gonna try god of war and c if it still does this.
Core2Duo E8400 @3.9GHZ
Radeon 4890
4G DDR2 @869MHZ
Reply
#7
Q9550 @3.86GHz
AMD 6950 2GB
4GB of ram

I just tried out GTA: Sand Andreas and it's another heavy hitter title. I'm getting around high 40's -60+ fps in native mode. Game like this required a high overclock of a Core i7 (Sandy Bridge) system.
Reply
#8
REEEEEEEEEEEEEEEEEEE!!1!!@11!!!! hurrrr thanks tuanming. i guess manhunt 2 also hits hard cuz its made by the same ppl and the engine looks similar. my fps would jump to 60 when im looking away from the city. but when im looking at it my frames stumple down to like 30. i was thinking something was wrong with my computer. go figure i pick 2 hard to emulate games. thank you everyone for your comments. i will post back here if i have problems with non-rockstar games.
Core2Duo E8400 @3.9GHZ
Radeon 4890
4G DDR2 @869MHZ
Reply




Users browsing this thread: 1 Guest(s)