Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
final fantasy x (occasional slowdowns)
#1
hi there.

i just want to ask if occasional slowdowns in ffx are normal.

the game runs smoothly, almost perfectly on my system. however, when the scene changes to a broader area (e.g. first scene in highlands right after luca, where there are lots of sky above), the game like --- 'lags', the rendering becomes so slow, i assume the frame rate goes down. this is the only problem i experience.

o, btw, also, when rendering animations of 'demi', the backward action of the demi just before it disappears is kinda choppy too.

btw, i'm running win 7 on a dual core 2.8ghz, 2 gb of memory, 286mb of graphics ram with onboard intel graphics accelerator (supports sse2, and sse3), with directx11 as default.

i know my system's not that powerful but it's able to run the emulator pretty smoothly except for those rare occasions i mentioned above.

if somebody can tell me what's wrong or what modifications/adjustments should i do to improve my gaming, it'll be appreciated.

tnx.
Reply

Sponsored links

#2
A couple of the spells will cause massive slowdowns in the game, nothing that can be done with that. The other slowdown is probably associated with your incredibly terrible onboard video.

Don't use DX11 mode... It's early, buggy, and probably SLOWER than DX10 or DX9 modes and doesn't contain any new features over DX10.
[Image: 2748844.png]
Reply
#3
Enabling the "native" option in GSdx might be able to help you a bit, also enabling/disabling "Allow 8-bit texture" might give a difference as well. Other than that not much you can do really, try the latest beta if you arent already and as Koji said you're better off using the DX10 renderer in GSdx as well (maybe DX9 in this case since FFX doesnt benefit much of DX10 and can be slower for you).

http://forums.pcsx2.net/thread-3716.html
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
i knew it..haha.

however, i did some research an found out that intel onboard cards are not compatible with dx10, i probably should stick with dx9. (gsdx dx10 mode just crashes).

unchecking 8-bit textures doesn't achieve anything but make the graphics look bad XD

when i check the native d3d option, it results to a 'not-so-crisp' screen.

anyway, i'd probably buy a newer vid card, something that supports at least pixel shader 2.

anyway guys, last questions:

[1] when i press escape(fullscreen mode), the screen becomes uncontrollable, meaning - i am unable to control everything - even alt+tab to switch windows. (is this a bug or am i doing something wrong).

[2] F8 for screenshots doesn't seem to work, i pressed f8 several times but no sc appears on the screenshots folder, why is this so?
Reply
#5
Make sure you're using lilypad for your controller plugin. ssxpad doesn't work with those shortcuts (if memory serves correctly).

As for escape causing lockup from fullscreen mode, that isn't supposed to happen and again may be graphics related... The intel boards handle 3d quite poorly, and switching video modes occasionally can cause crashes/lockouts like that.
[Image: 2748844.png]
Reply
#6
I think you need to create both a "snap" and a "snaps" folder for screenshots to work correctly, if you are running D3D9 fullscreen it's a little tricky, you can try the "misc > close GS window on esc" on PCSX2 or the "safe fullscreen exit" option in the lilypad controller plugin to see if they do any good (make sure you choose lilypad for both first and second controller plugins).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)