Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
final fantasy xii , direct3d10 , graphics glitches
#1
ok this is my first post on this site ill try and put as much information needed

as the heading says i get graphics glitches when i try and play ffxii on directx 10
   
   
my system specs are ( its a laptop )

Operating System = Microsoft windows 8 (build 9200), 64-bit
RAM = 3894 MB
CPU name = Intel® Core™ i5 CPU M 430 @ 2.27GHz (2 cores , 4 threads )
CPU speed = 2.49 ghz
x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

my graphics card is an intel hd graphics
( the one built into the cpu)

settings im using in the newest svn build
all setting are default apart form the gsdx settings
ive only changed the resolution to 512 x 448
   

any ideas would be appreciated also i can run it on direct x 11 but the speed is slowed down by more than half

thanks
Reply

Sponsored links

#2
I don't see any glitches in those screen shots. Only your aspect ratio is way off. Try setting it to 16:9
-PC Specs-
Intel i5 3570k 3.8Ghz
8gb DDR3 Kingston Hyper X 1600Mhz
MSI GTX 770 2gb OC Gaming Edition @ 1100Mhz
LG Full HD LED 32" Display
Windows 10 Pro x64 
Reply
#3
Quote:ive only changed the resolution to 512 x 448

You found your problem...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
yea thats my fault i should have added images from an non glitched version

here are images for comparison

   

also when im in the equipment select menu the frames drop drown to 25

(03-26-2013, 09:59 PM)jesalvein Wrote: You found your problem...

nope that not it i changed it around to naive and 2x native also set the gs window setting to 16:9 aspect ratio
Reply
#5
about the fps drop : try enabling/disabling 8 bit textures.
About the "glitches" : could you please describe what you mean ? It's a long time since I played it and I don't see any difference (except aspect ratio) between both screenshots
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
are you talking about all those black dots all over the character models?
Reply
#7
my bad

the parts inside blue circles

glitch image 1 on dx10
   

how it should be
   

glitch image 2 on dx10
   

how it should be
   

the should be's are taken from dx 9

also i tried turning on 8bit textures that fixed the glitches in image 2 but glitches in 2 are still there
Reply
#8
Avoid using DirectX 10 on Intel HD 1000. I have experienced trash black pixels on all games with it.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply




Users browsing this thread: 1 Guest(s)