Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[fixed rev1351] unaligned memory pointer passed to readtexture ICO Game using GSDX
#1
Question 
Tested game ICO pal [SCES_507.60] [CRC=5c991f4e]
ALL the hacks and microvu off
Pcsx2 SVN rev1340/1341
Cpu eerec on, vurec0 and vurec1 on, MTGS on
Plugins used GSDX svn 1340/1341 Directx9 or directx10 hardware mode success (no idea if it work on revisions oldest)

Photo GSDX hardware

   

photo GSDX software not present

   

Console error continue unaligned memory pointer passed to readtexture

   
[Image: mypc.gif]
Reply

Sponsored links

#2
could you make a .gs and upload it? (shift+f8)
Reply
#3
(06-07-2009, 09:48 AM)Gabest Wrote: could you make a .gs and upload it? (shift+f8)

okay upload .gs 6Mb compress file .7z


Attached Files
.7z   gsdx_20090607113719.7z (Size: 902,66 KB / Downloads: 128)
[Image: mypc.gif]
Reply
#4
The crc is missing from the .gs, it seems pcsx2 did not set it, and without that fixes cannot be applied. Did you happen to start it with run/execute?
Reply
#5
I think I have the same version of the game. The problem is ICO doesn't work from Run->CDVD. The only way to start this game is use run->execute.
Reply
#6
Ah, yea the detect-CRC thing when loading from Run->Execute got broken again a while back. I dunno how that happens. I've fixed it like 3 times now. I think Arcum's cleanups of cdvd keep inadvertently deleting the code or something. I'll go and re-re-re-fix it Smile
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#7
I've fixed the CRC bug in the latest SVN -- http://code.google.com/p/pcsx2/source/detail?r=1349 . So grab that and re-test it and see if you still have issues.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#8
Yeah thanks

view work again ico (run -> ejecute)

photos

   

and present error console ( although at first sight does not affect anything in the gameplay but the reported )

   

added .gs file


Attached Files
.7z   gsdx_20090608210320.7z (Size: 778,38 KB / Downloads: 108)
[Image: mypc.gif]
Reply
#9
Strange I never run anything with execute, ico boot just fine here with peops.
Reply
#10
Fixed the error on rev1351
[Image: mypc.gif]
Reply




Users browsing this thread: 1 Guest(s)