Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fps is 40 while EE:46%, GS:45%, VU:39%
#1
I play MGS 3 on my desktop pc and result is:
[Image: attachment.php?aid=31494]

EE, GS and VU are under 100 %, then why is the game slow?

mu pc is:
core i5 760 2.8 ghz turbo boost 3.33 ghz -- 4 gb kingston ddr3 1333 mhz saphire hd 5770 -- asus p7p55LX mainboard -- windows 7 x64

pcsx2 version:5133
and these are settings:
[Image: attachment.php?aid=31495]
[Image: attachment.php?aid=31496]
[Image: attachment.php?aid=31497]
[Image: attachment.php?aid=31498]
[Image: attachment.php?aid=31499]


Attached Files Thumbnail(s)
                       
Reply

Sponsored links

#2
(03-30-2012, 06:05 PM)fat2019 Wrote: EE, GS and VU are under 100 %, then why is the game slow?

Such a result almost indicates that you're GPU limited. (Remember that GS% is the amount of time the CPU spends on GS emulation, not the GPU). Does it get faster when you drop to native internal resolution?
Reply
#3
i tried two configuration: original ps2 resolution native and scaling 3x native. both are 40 fps (but 3xnative is always 40 fps while other is 60 with other parts of the game).

Reply
#4
and i5 760 is quad core so i think ee, gs and vu are assigned to independent cores.

these are tekken 5 results:
fps:60 EE:65%, GS:37%, VU:68%
Reply
#5
You only get the three seperate units (EE, GS and VU) on their own threads with MTVU enabled.
This can cause slow downs, as well,
especially when the GS thread gets limited.

When you are at Native internal resolution,
your processor is the bottleneck of potential.

By 3x Native resolution,
you encounter limitations from your graphics unit.
Reply
#6
set EE to the next setting 1.5x and it SHOULD be fine. I actually found a few games where the EE is slower, and PCSX2 cannot accommodate the nees of the game, you have to do it manually. (or at least that's the impression I get)
Reply
#7
(03-30-2012, 08:51 PM)Saiki Wrote: set EE to the next setting 1.5x and it SHOULD be fine. I actually found a few games where the EE is slower, and PCSX2 cannot accommodate the nees of the game, you have to do it manually. (or at least that's the impression I get)

How will i do that?
Reply
#8
emulation settings: EE cycle Rate. just tick it up one setting.
Reply
#9
(03-30-2012, 08:59 PM)Saiki Wrote: emulation settings: EE cycle Rate. just tick it up one setting.

there are three options with EE cycle Rate:1, 2 and 3. I tried three of them but still 40 fps.
Reply
#10
odd.. then there's some other factor.. post your gsdx.ini here please? (contents, NOT attachment)
Reply




Users browsing this thread: 1 Guest(s)