Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fps on my kingdom hearts game is slow!!! help
#1
so i have tried almost everything in settings to help me up my fps on my laptop but i cannot seem to make it work, at the beginnning of the game everything was perfect then it gets to destiny islands and the fps slow down so much and then go back up suddenly back to 60+. It happens in scenes and in game. i would like some suggestions as to what can be done.
my specs for this laptop are as follow

processor: intel core® Core™ i7-4700HQ CPU @ 2.40GHz
asus
8GB of ram
64 bit
windows 8.1


i should aslo mention that the EE% is very hihgh 90-100 and the GS% is 35 and gets worse.
Reply

Sponsored links

#2
Your cpu is struggling.
Set windows power plan to performance mode and make sure you aren't running on batteries
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
And Destiny Islands is known to struggle even the most beefy CPU.
[Insert Witty Sig Here.]
Reply
#4
Post your pcsx2 settings.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
Try software mode and set the extra rendering threads to 3.
Reply
#6
(01-04-2015, 01:44 PM)KeyToTruth12 Wrote: And Destiny Islands is known to struggle even the most beefy CPU.
It should be fine on that CPU. I was pulling 85FPS on my pc
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#7
sooo i feel really stupid... i totally forgot that i needed to change the batteries settings.... it was running on low cpu usage to save power haha. It is working perfect now, however some scenes do seem to slow down, mainly in destiny island... that is so bizzare.
Reply
#8
(01-04-2015, 09:27 PM)army1421 Wrote: sooo i feel really stupid... i totally forgot that i needed to change the batteries settings.... it was running on low cpu usage to save power haha. It is working perfect now, however some scenes do seem to slow down, mainly in destiny island... that is so bizzare.

All you did here was set to high preformance right? not change another setting called batteries? Sorry for being noob just trying to make sure of some things.
Reply
#9
(01-04-2015, 10:04 PM)proofofexistence Wrote: All you did here was set to high preformance right? not change another setting called batteries? Sorry for being noob just trying to make sure of some things.

yes correct, i only changed from power saving to high perfomance.
Reply
#10
(01-04-2015, 10:04 PM)proofofexistence Wrote: All you did here was set to high preformance right? not change another setting called batteries? Sorry for being noob just trying to make sure of some things.

In your case it won't matter. I saw the specs of your system that you posted and they're just not good enough. Like many others already told you.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply




Users browsing this thread: 1 Guest(s)