Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
graphics glitches
#1
[Image: l1OkDBL.png]

So here is the problem I am getting when trying to play Baldur's Gate Dark Alliance. I have tried both an ISO and straight from the disc.
I am able to control the game, but it will freeze after the Black Isle Studios into plays.

specs:
gpu: 980ti
cpu: i7 4970k
ram: 16gb 1600mhz
psu: 1000w

If I left anything out, let me know!
Reply

Sponsored links

#2
Tried OGL renderer ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
For the Snowblind games, any renderer other than D3D9 hardware mode should work fine from 1.4 stable onward.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
If you're using a (Hardware) renderer, make sure your resolution is set to Native or one of the _x Native modes - do not use a custom resolution for BG: DA, it will cause stretched / broken graphics on the right half of the screen.

Not sure what would cause the game to freeze. What version of PCSX2 are you using? Speedhacks?
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#5
using 1.4.0 at the moment at native resolution, getting into game now, but just need the right combination of settings to stop going slow-mo. In the first area (elfsong tavern) I go slow mo in the middle of the room, but normal speed at the save point in the top corner
Reply
#6
If you upgrade to one of the recent development builds from here, you'll be able to get a huge boost in performance by enabling the "Fast Texture Invalidation" hack in GSdX settings.

I use these settings with the latest build:
GSdX
Speedhacks (other emulation settings same as "safe" preset)

In the middle of the Elfsong Tavern, I get full speed with a bit of breathing room (~80fps with framelimiting disabled).
Your PC should be able to do even better Smile
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#7
Yeah newer GIT with Fast Texture Invalidation and 8bit textures ticked help massively with the Snowblind engine games. Also OpenGL hardware mode with 3x should run fine for you once you enable the other 2 options.
Reply




Users browsing this thread: 1 Guest(s)