Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
libfontconfig on Snow Leopard
#1
Hey, all. I finally found my OSX install CD, and added all the X11 optional installs for my 13" MacBook Pro 5,5 (Core2Duo 2.53, 4GB RAM, GeForce 9400M). I've reinstalled the NVidia CG toolkit (Feb 2011), XQuartz 2.5.0, PCSX2 0.9.6 and the ZZogl plugin.

I was getting the "libXplugin.1.bin" error before installing X11. Now, after the installation, I'm getting the following error:

Code:
dyld: Library not loaded: /usr/X11/lib/libfontconfig.1.dylib
  Referenced from: /usr/local/lib/libgtk-x11-2.0.0.dylib
  Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires version 6.0.0 or later, but libfontconfig.1.dylib provides version 5.0.0
pcsx2.sh: line 2: 11017 Trace/BPT trap          ./pcsx2

I ran the OSX Software Update after installing X11, but it didn't seem to do anything. Anybody have a solution for this problem? Any help would be immensely appreciated! Thanks!
Reply

Sponsored links

#2
have you tried the newest version of x11 from the website? version 2.6.2? (its snow leopard only, if you have leopard version 2.6.1 is the last one thats leopard compatible)
http://xquartz.macosforge.org/trac/wiki/Releases

also which version of max OS X are you on? more specifically, are you on tiger, leopard or snow leopard and of that osx title which version of it are you using?

There are separate versions of pcsx2 for leopard and snow leopard and im not sure tiger is supported. i kinda doubt it.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#3
Yes. I just checked, and 2.6.2 is the version I currently have. I'm running OSX 10.6.7 (Snow Leopard).
Reply
#4
try redownloading/installing
thats about all i can suggest
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#5
Thanks for the advice. I'll keep my fingers crossed.
Reply
#6
also if you have not rebooted after any of these changes i would suggest that. its complaining about the library being version 5 when it needs version 6 or something so i would just have to suggest being totally updated (i think a new snow leopard 10.6.8 just got released although i doubt it would do much) and then rebooting after so that all the libraries are up to date.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#7
(06-30-2011, 01:22 AM)AFX-6502 Wrote: Hey, all. I finally found my OSX install CD, and added all the X11 optional installs for my 13" MacBook Pro 5,5 (Core2Duo 2.53, 4GB RAM, GeForce 9400M). I've reinstalled the NVidia CG toolkit (Feb 2011), XQuartz 2.5.0, PCSX2 0.9.6 and the ZZogl plugin.

I was getting the "libXplugin.1.bin" error before installing X11. Now, after the installation, I'm getting the following error:

Code:
dyld: Library not loaded: /usr/X11/lib/libfontconfig.1.dylib
  Referenced from: /usr/local/lib/libgtk-x11-2.0.0.dylib
  Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires version 6.0.0 or later, but libfontconfig.1.dylib provides version 5.0.0
pcsx2.sh: line 2: 11017 Trace/BPT trap          ./pcsx2

I ran the OSX Software Update after installing X11, but it didn't seem to do anything. Anybody have a solution for this problem? Any help would be immensely appreciated! Thanks!

the X11 will is installed under /opt/X11 but the pcsx2 will be searching inside /usr/X11 copy /opt/X11 to /usr/X11
Reply




Users browsing this thread: 1 Guest(s)