Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
loading Saved States = graphical errors
#1
When I load a saved state that was SAVED from the same screen I am on, the graphics appear normal. Maybe it is because the textures are already loaded.

If I load that same saved state from a different screen, the graphics / textures are garbled.

I will be glad to provide the details, but just in general terms, is this how saved states work?
Or is there usually a work around?

Dig
Reply

Sponsored links

#2
yes give full details (plugins used, version of pcsx2, pc spec Tongue)
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply
#3
0.96
I guess the default plugins
GSDx 890
Direct3D9 Hardware
FrameSkip
Several Speed Hacks:
X2 Cycle
INTC
IOP X2 Cycle
WaitCycle Sync Hack

DISGAEA Hour of Darkness

AMD 3800 single core 2.4 Ghz
AGP X1650 Pro 512ram
2gb Ram
XP Home
PC is weak, hence the 2D game

With the speedhacks and frameskip enabled, the game appears to play fine! I would like to know if there is some additional settings I need to try so the SaveStates have normal graphics.

I have tried various combinations of the graphics settings and / or turning off the speed hacks / FrameSkip etc. So far, I still have the graphics issues with SaveStates from a different screen....For example, if I am in the "lobby" and load a SaveState from the lobby, the graphics are normal. If I am in a "battlemap" and load the lobby SaveState, the graphics are partially missing or garbled.

Seriously, the fact my PC will play that game at all is pretty amazing. Eventually I will buy a new PC.

Dig
Reply
#4
Can anybody help with my Disgaea Saved State questions?

Dig
Reply
#5
Sounds like a GSdx bug...can you test it with ZeroGS and see if it happens with it too? You could also try the latest PCSX2/GSdx beta.
[Image: newsig.jpg]
Reply
#6
Quote:For example, if I am in the "lobby" and load a SaveState from the lobby, the graphics are normal. If I am in a "battlemap" and load the lobby SaveState, the graphics are partially missing or garbled.
Sounds like the graphic elements or whatever aren't properly initialized by the game, hence the garbage you see.
Reply
#7
(05-06-2009, 02:35 PM)Bositman Wrote: Sounds like a GSdx bug...can you test it with ZeroGS and see if it happens with it too? You could also try the latest PCSX2/GSdx beta.

I have resolved the issue! I was loading ( and saving ) states from the menu: FILE - STATES - LOAD. When I simply use the F3 key, it loads without graphical errors regardless of the screen that I am on.

As far as beta-1059, it crashes when I try to Save a state. When I restart and load that saved state, it says it is either corrupt or incomplete. I will stick with 096 for now.

Dig
Reply
#8
(05-07-2009, 03:04 AM)dig314 Wrote: I was loading ( and saving ) states from the menu: FILE - STATES - LOAD.
hmm yes, i have seen people have that problem when doing it that way Smile, glad you got it worked out Smile
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply




Users browsing this thread: 1 Guest(s)