Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
low CPU usage but high EE
#1
hey guys,

I play FFXII [2cores Intel Core i5 2,53Ghz with TurboBoost to 2,8] on the lastest version of psx2 - 0.9.8. During the whole game my EE is almost 100% but CPU usage is sth about 30-40% ... isnt it strange? I am not sure, but is it a good or bad situation?

Of course the game is not so ''fluent" as I would like to have and I thought that when the CPU usage would be higher, EE would be on the other hand lower...

Thanks...
Reply

Sponsored links

#2
You should say the CPU full name, instead of its brand name and clock speed. I can guess you have a dual core laptop i5 (due to its low clock speed), more exactly the i5 460M.

Core i5 has a technology called HyperThreading. This technology allow the operating system to assign 2 virtual cores to each physical core. These virtual cores share workload between them. PCSX2 uses 2 cores. If you look at the Task Manager, only two cores are working, the others are idle and the total CPU usage is 40 → 50%. But in fact these working core share workload with the others. In other word they're using the full power of their corresponding physical core.

You can test it yourself by turn of HyperThreading and see your CPU reaches 80% → 90% usage with two cores and you gain no additional FPS of course.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#3
Might be worsen than it; EE tells how much of the CPU power it "gets" it is using, not the absolute CPU load... now, PCSX2 uses in fact two cores, the other is dedicated to GS, let's imagine it is low loaded, possibly near 0% loaded... the OS see the average load as low and will not activate the turbo... yet worse it may keep the CPU underclocked which worsens EE situation which in turn let GS yet more idle...

The first thing to do is insure Windows is using a performance power plan to force the CPU to nominal speed instead reducing it's clock in what it "thinks" is low demand. Now come the CPU proper way to deal with the turbo feature... lets hope using that performance plan is enough to avoid the issue triggering.

Changing the power plan to performance is done in the Windows Control Panel, in the "Power Options" icon... from there, you may need to force it to show all available plans, there is a little box to do it. Remember to return the default power saving afterward, mainly if on a laptop.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)