Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pcsx2-5391 not recognising plugin? - SOLVED
#1
downloaded 1 of the more recent builds of pcsx2 and i wanted to do that because of the new gamefix for fmv's (goes into software mode when it detects an fmv)

but now im with the following problem:

i used to play digre of cerberus alot on the cpsx2 because its awsome and now with the newer revision i can have a better experience then with the other build i have been using (1.0.0)

so i copied the special plugin for that game so the screen loosk normal instead of split in half (one side bright other side dark) and copied the plugin into the plugin directory, but as soon as i want to select that plugin it doesnt see it. i cant select in anyway.. also the log gives me the following error that has probably has something to do woth the problem im having.

Plugins loaded successfully.

(GameDB) 9640 games on record (loaded in 149ms)
Path: D:\programma\pcsx2-5391-windows-x86\plugins\GSdx32-AVX-r5390.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\programma\pcsx2-5391-windows-x86\plugins\GSdx32-AVX-r5390.dll
Path: D:\programma\pcsx2-5391-windows-x86\plugins\GSdx32-AVX.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\programma\pcsx2-5391-windows-x86\plugins\GSdx32-AVX.dll
Path: D:\programma\pcsx2-5391-windows-x86\plugins\GSdx32-SSE4-r4734m-FF7_DoC.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\programma\pcsx2-5391-windows-x86\plugins\GSdx32-SSE4-r4734m-FF7_DoC.dll
Path: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl-cg-r5389.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl-cg-r5389.dll
Path: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl-cg.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl-cg.dll
Path: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl-r5389.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl-r5389.dll
Path: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\programma\pcsx2-5391-windows-x86\plugins\ZZOgl.dll


see attachment for more info.


Attached Files Thumbnail(s)
   
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply

Sponsored links

#2
that error usually appears when a CPU instructionisnt available, such as AVX on anything before ivy bridge or certain SSE's on AMD

do you have all the ZZOGL prerequisites? - is that what you are attempting to use?
[Main Computer] - CPU: I7 950 @ 3.2Ghz | GPU: Twin Nvidea GTS 450's SLI'd | RAM: 8GB DDR3 - 1600MHz | OS: Windows 7 Ultimate x64 | EMU: PCSX2 v1.0 | GS: GSdx32-SSE4 | SPU2: SPU2-X | PAD LilyPad | CDVD ****
Reply
#3
zzogl requires the 32bit versions of cg.dll and cggl.dll
Reply
#4
do i have what? xD

the emulator is functioning properly and the plugin i copied was from an earlier revion i used so i dont see the problem in not displaying the plugin.
as you can see in the left corer i have the GSdx32-SSE4-r4734m-FF7_DoC.dll in the plugin folder but it doesnt show up when im seleceting a new plugin.

my i5 760 can play with sse4 that is for sure because i have played with that plugin from the earlier build.
so i dont really get what ZZOGL is but i dont think my processor doesnt support sse4 :/

edit:

i have:

ZZOGL.dll
zzogl-cg.dll
zzogl-cg-r5389.dll
zzogl-r5389.dll

in my plugin directory
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#5
it does support sse4, so its odd that its throwing up a false negative

and the ordinary sse4 plugin loads... try recopying it or re downloading it incase the checking mechanisim became corrupted? - is that in the plugin or pcsx2?
[Main Computer] - CPU: I7 950 @ 3.2Ghz | GPU: Twin Nvidea GTS 450's SLI'd | RAM: 8GB DDR3 - 1600MHz | OS: Windows 7 Ultimate x64 | EMU: PCSX2 v1.0 | GS: GSdx32-SSE4 | SPU2: SPU2-X | PAD LilyPad | CDVD ****
Reply
#6
you require w32pthreads.v3.dll to load that version of the plugin
Reply
#7
also i get that plugin error only with that new revision...

EDIT:

squall, where do i put the w32pthreads.v3.dll?
just in the plugin directory?

also why do i need this all of a sudden when the previous build didnt need that to run the plugin?
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#8
it goes in the executable folder
Reply
#9
(08-30-2012, 03:40 PM)Squall Leonhart Wrote: it goes in the executable folder

did what you said but it still gives me the same error and it still doesnt see the plugin (the one that was in the executable folder was the w32pthreads.v4 version not 3 so i was hoping for some results but allas)

rama made this one i believe so maybe he/she knows something more >.<
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#10
ah, it might not be missing that afterall,

can you upload the plugin somewhere so i can take a look at it in depends
Reply




Users browsing this thread: 1 Guest(s)