Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pcsx2 crash with gsdx in directx mode (solved)
#1
Hi,
I know this is for sure a problem with the configuration of the OS but I can't fix it. When I use any of the directx modes pcsx2 crash with:

"Runtime library Visual c++", runtime error.

The OpenGL version work but seems slow and the graphics much worse than it should be.

Specs:
w8.1 x64 (visual c redist installed)
i7 2600k
16GB
GTX 570 (tried with 327.x [current, seems faster in opengl mode], 34X.X and latest beta)
PSU 850W
Crucial MX100

The log seems normal, the latest dev version also crash.

Code:
PCSX2 1.3.0-20141004113334 - compiled on Oct  4 2014
Savestate version: 0x9a0a0000

Host Machine Init:
    Operating System =  Microsoft  (build 9200), 64-bit
    Physical RAM     =  16363 MB
    CPU name         =  Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
    Vendor/Model     =  GenuineIntel (stepping 07)
    CPU speed        =  3.391 ghz (8 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 1f9ae3bf
    x86EFlags        =  28100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: E:\pcsx2-v1.2.1-639-gfa3db52-windows-x86\plugins\GSdx32-SSE4.dll
Windows 6.2.9200
    Binding  PAD: E:\pcsx2-v1.2.1-639-gfa3db52-windows-x86\plugins\LilyPad.dll
    Binding SPU2: E:\pcsx2-v1.2.1-639-gfa3db52-windows-x86\plugins\SPU2-X.dll
    Binding CDVD: E:\pcsx2-v1.2.1-639-gfa3db52-windows-x86\plugins\cdvdGigaherz.dll
    Binding  USB: E:\pcsx2-v1.2.1-639-gfa3db52-windows-x86\plugins\USBnull.dll
    Binding   FW: E:\pcsx2-v1.2.1-639-gfa3db52-windows-x86\plugins\FWnull.dll
    Binding DEV9: E:\pcsx2-v1.2.1-639-gfa3db52-windows-x86\plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9653 games on record (loaded in 149ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.2.9200
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: E:\dq8.iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2041088 sectors)
    Opening USB
    Opening FW
    Opening DEV9
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
* SPU2-X: Waiting for DSound thread to finish...(pxActionEvent) The MTGS thread has become unresponsive while waiting for the GS plugin to open.(thread:EE Core)
Done.
    Closing PAD
    Closing GS

I tried removing Visual C++ redistributable 2013 X64, 2010 and 2005 but doesn't either:
capture of visual c installation

I have also problem with XAudio mode instead of direct sound, it crash with "Failed to init XAudio2 engine". It works fine in DirectSound mode.
Cause of this error I think it might be a DirectX problem but I don't know how to fix it, I tried reinstalling it (http://www.microsoft.com/en-us/download/...aspx?id=35) but it fails with this error, I suppose is cause w8.1 already includes dx11:

Code:
--------------------
[12/21/14 09:23:38] module: DXWSetup(Mar 30 2011), file: dxwsetup.cpp, line: 229, function: CDXWSetup::InitInstallEngine

    Sections are not initialized.

--------------------
[12/21/14 09:23:38] module: DXWSetup(Mar 30 2011), file: psheets.cpp, line: 705, function: PreinstDlgProc

    CDXWSetup::InitInstallEngine() failed.
Code:
12/21/14 09:23:33: DXWSetup: ***** DXWSETUP *****
12/21/14 09:23:33: DXWSetup: WinMain()
12/21/14 09:23:33: DXWSetup: IsIA64(): not IA64.
12/21/14 09:23:33: DXWSetup: Unable to get Version on target file C:\Windows\system32\directx\websetup\dsetup.dll
12/21/14 09:23:33: DXWSetup: Installed file C:\Windows\system32\directx\websetup\dsetup.dll
12/21/14 09:23:33: DXWSetup: Unable to get Version on target file C:\Windows\system32\directx\websetup\dsetup32.dll
12/21/14 09:23:33: DXWSetup: Installed file C:\Windows\system32\directx\websetup\dsetup32.dll
12/21/14 09:23:33: DXWSetup: GetDXVersion(): Unable to get RC string from registry.
12/21/14 09:23:33: DXWSetup: DirectX Version: 4.09.00.0904.00
12/21/14 09:23:33: DXWSetup: Setup Version: 4.09.00.0904.00
12/21/14 09:23:33: DXWSetup: A newer version of DirectX have been installed already.
12/21/14 09:23:37: DXWSetup: CDXWSetup::CDXWSetup()
12/21/14 09:23:37: DXWSetup: CDXWSetup::DownloadDXUpdate()
12/21/14 09:23:37: DXWSetup: OnEngineStatusChange(): EngineStatus = 0x1, SubStatus = 0x0
12/21/14 09:23:37: DXWSetup: OnEngineStatusChange(): EngineStatus = 0x3, SubStatus = 0x0
12/21/14 09:23:37: DXWSetup: OnEngineStatusChange(): EngineStatus = 0x2, SubStatus = 0x0
12/21/14 09:23:37: DXWSetup: OnStartInstall(): DLSize = 81, InstallSize = 0
12/21/14 09:23:37: DXWSetup: OnStartComponent(): ID = DXUpdate, DLSize = 81, InstallSize = 0, str = %DirectX_Setup%
12/21/14 09:23:37: DXWSetup: OnComponentProgress(): Phase = 0, Progress = 0
12/21/14 09:23:38: DXWSetup: OnStopComponent(): ID = DXUpdate, hr = 0x0, Phase = 9, str = %DirectX_Setup%, status = 0x0
12/21/14 09:23:38: DXWSetup: OnStopInstall(): hr = 0x0, str = (null), status = 0x0
12/21/14 09:23:38: DXWSetup: OnEngineStatusChange(): EngineStatus = 0x3, SubStatus = 0x0
12/21/14 09:23:38: DXWSetup: WM_APP_DOWNLOADDXUPDATE
12/21/14 09:23:38: DXWSetup: CDXWSetup::InitInstallEngine()
12/21/14 09:23:38: DXWSetup: CDXWSetup::InitInstallEngine(): Sections are not initialized.
12/21/14 09:23:38: DXWSetup: PreinstDlgProc(): CDXWSetup::InitInstallEngine() failed.
12/21/14 09:23:38: DXWSetup: WM_APP_ENDDOWNLOAD
12/21/14 09:23:39: DXWSetup: CDXWSetup::~CDXWSetup()
12/21/14 09:23:40: DXWSetup: CreatePropertySheet() returns -9.
12/21/14 09:23:40: DXWSetup: Deleted file C:\Windows\system32\directx\websetup\dsetup.dll.
12/21/14 09:23:40: DXWSetup: Deleted file C:\Windows\system32\directx\websetup\dsetup32.dll.

Thanks!
Reply

Sponsored links

#2
update directx with this
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Now works.
For some reason I downloaded that package before but abort the installation since I though I was only for app developers. Yesterday I lost the afternoon with this Blush

Thanks jesalvein !
Reply




Users browsing this thread: 1 Guest(s)