Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pcsx2 crashes at booting
#1
Hi,
I've just installed pcsx2 in my fedora22 from the repo, i run it and configured it (didn't change anything in the default settings), also the bios and everything (i think).
I also got my dvd (dragon ball budokai tenkaichi 2) in the laptop and made an imge of the disc (.img) as somewhere i read it was suggested to run from an image if you wanted better performance.
However, every time i try to boot (full and fast) the iso file, pcsx2 crashes and fedora reports it had some problem and crashed.
I am a bit of a newbie, could anyone help me?  maybe is something related to basic settings or else.

I run fedora 22 on an aspire e1-531 , with intel pentium CPU B950 @ 2.10GHz × 2 , 64 bit and a intel sandybridge mobile as graphics. 4 Gb of ram

Thanks in advance!

UPDATE
I've tried changing the plugin configuration: the only one I've got alternatives to choose between is the GS. These are the results:
ZZ Ogl PG CG  0.3.0 [libzzogl-cg-0.3.0] -> the first i used as default, as already said everything just crashes at booting


ZZ Ogl PG  0.4.0 [libzzogl-0.4.0] -> at the beginiing it says he couldn't configure everything well and things may not work, now it just crashes immediately at booting

GSdx (GCC 5.1.1, SSE2) 0.1.16 [libGSdx-0.1.16] -> with this it starts booting and the window at least stay on the screen for more than one second, but rapidly crashes and show an error message (screenshoots attached)

Thanks again!


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
Your GPU is too old to support the proper OpenGL version needed to run the emulator. besides it would be too slow anyway.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
To doublecheck, run this command in terminal... glxinfo | grep -i opengl
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#4
(08-15-2015, 01:22 PM)DaTankAC Wrote: To doublecheck, run this command in terminal...  glxinfo | grep -i opengl

I got this output, can you confirm your previous statement?


Attached Files Thumbnail(s)
   
Reply
#5
http://people.freedesktop.org/~imirkin/g...l#v=Vendor

Older Intel gpu is missing a lot of new features needed. Generally minimum OpenGL version must be 3.3 with a variety of newer extensions. Try running pcsx2 from terminal. If it crashes and indicates an X server error in the terminal then it's definitely a gpu problem.

Of course, Gregory is the master of all this. If there is anything I missed or got incorrect he will correct me (as my main testing periods were about 3 years ago, before all these rapid changes in the past few months).
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#6
SB must work. Please run it from a terminal and copy/paste the error message
Reply
#7
(08-15-2015, 03:58 PM)DaTankAC Wrote: http://people.freedesktop.org/~imirkin/g...l#v=Vendor

Older Intel gpu is missing a lot of new features needed.  Generally minimum OpenGL version must be 3.3 with a variety of newer extensions.  Try running pcsx2 from terminal.  If it crashes and indicates an X server error in the terminal then it's definitely a gpu problem.

Of course, Gregory is the master of all this.  If there is anything I missed or got incorrect he will correct me (as my main testing periods were about 3 years ago, before all these rapid changes in the past few months).

Thanks for your answers, i tried and i got the errors in the attachment. I think you got the point


Attached Files Thumbnail(s)
   
Reply
#8
Quote:OpenGL renderer string: Mesa DRI Intel® HD Graphics 5500 (Broadwell GT2)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.6.3 (git-ccef890)

Code:
(pcsx2:2272): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «adwaita»,
(pcsx2:2272): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «adwaita»,
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Interface is initializing.  Entering Pcsx2App::OnInit!
Applying operating system default language...
Loading language translation databases for 'Spanish' [es_ES]
Command line parsing...
Command line parsed!
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Failed to create the opengl context. Check your drivers support openGL 3.3. Hint: opensource drivers don't
libEGL warning: DRI2: failed to open i965 (search paths /usr/lib/dri)
libEGL warning: DRI2: failed to open swrast (search paths /usr/lib/dri)
Reply
#9
You miss the 32bits version of the driver.
Reply
#10
Thanks, sorry for being a noob, could you copy&paste the command I should type in the terminal or the easiest way to install the 32bits version of the driver.
Thanks.
Reply




Users browsing this thread: 1 Guest(s)