Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
performance issues
#1
I'm looking for some help getting my performance up. When I load games from CD(all I have tried so far) I get 60FPS all the way up to when i get into the play area of the game then my FPS drops down to 20ish. So far with some tweaking I have gotten it to go up to about 26FPS. I have Tired the speed hacks but all they seem to do is lower my FPS more(I dunno how that's possible). The main game i'm using to test with is FFX NTSC. My signature should have all my specs if something is missing or you want to know more info then what would fit just ask.
CPU: AMD PHenom 8750 Triple-Core 2.4GHz
RAM: 4MB
DX: DirectX 10
Display: ATI Radeon HD 3800 Series 3MB
HDD: 300GB Western Digital
OS: Windows Vista Home 32-bit SP1
Reply

Sponsored links

#2
With the pcsx2 beta you are using set the "VU Cycle Stealing" speedhack to 'slight' nothing higher, are you sure your speedhacks make the game slower? any speedhack in particular doing this?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
play the game directly from your hdd with linuziso as cdvd plugin, use imgburn, alcohol 120% or similar to rip it.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#4
Ok well I have gotten my FPS to rise up to about 40. It jumps up to 60 every once in a while but it can also fall down to about 8, especially when there is water effects. I changed my graphics plug-in to ZeroGS 0.97.1 - Bilinear filtering(on), resolution 960 x 540, FFX hack - 00000080(on). Changed sound to P.E.Op.S. SPU2 1.9.0 - volume loudest, reverb spu2 reverb, interpolation gaussian interpolation. changed cdvdrom to linuz iso cdvd 0.9.0, I have been using the .MDF file i got from Alcohol 120%

CPU Config - EERec - EE/IOP recompiler(on), VU0rec(on), VU1rec(on), Multi threaded GS mode(on), Frame Limiting(Limit),

Speed Hacks - EE sync hacks(use x2 cycle rate), EE Misc Hack(INT Sync HAck, Enable IOP x2 Cycle Rate, WaitCycles Sync Hack, Idle Loop Fast-Forward, all on), VU Hacks(Status Flag Hack, Min / Max Hack, on), VU Cycle Stealing(maxed)

Advanced options - EE Recs Options; Round Mode(Shop/zero), Clamp mode(normal), Denormals are Zero(on). VU Recs Options; Round Mode(chop/Zero), Clamp Mode)normal), Denormals are Zero(on)

I've tried each speed hack by its self with both the zerogs and gsdx plugins, when using gsdx the speed hacks only slowed it down or had no improvement what so ever, but with zerogs there is a slight inprovement in the high range of my FPS but during certain events it slows it down to a crwaling 8 FPS. by setting all the speed hacks on i've been able to bring the FPS average to 40 FPS
CPU: AMD PHenom 8750 Triple-Core 2.4GHz
RAM: 4MB
DX: DirectX 10
Display: ATI Radeon HD 3800 Series 3MB
HDD: 300GB Western Digital
OS: Windows Vista Home 32-bit SP1
Reply
#5
do you use the latest beta revisions of the plugins, especially the gpu ones?
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#6
yes they are the latest gpu plugins both the gsdx and zerogs unless there has been a new version but out today i don't know of yet Huh
CPU: AMD PHenom 8750 Triple-Core 2.4GHz
RAM: 4MB
DX: DirectX 10
Display: ATI Radeon HD 3800 Series 3MB
HDD: 300GB Western Digital
OS: Windows Vista Home 32-bit SP1
Reply
#7
Dont use VU Cycle Stealing maxed, set it only to slight as it will cause problems for this game if any higher, try changing the clamp modes to none and you should be using GSdx really but if you keep using ZeroGS try turnng bilinear filter off. And yes actually there was a new version of GSdx today go to the GSdx thread Tongue
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
well, could you post some screens of your config? and why did you activate the vu hacks? afaik they only work with the new microvu. do you use microvu? if yes, dactivate it. it's still experimental and could be slower than the old vu recompiler.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#9
ok problem solved took those speed hacks off leaving EE's x2 cycle on and the idle loop fast forward and the VU cycle stealing to slight and turned the clamps on both the EE and VU to none and in game is sitting at 60ish FPS with the occasional slow down to 8FPS during heavy activity and I put the Anti-aliasing to 8X still using the zerogs tried the new gsdx and it still put me at 20FPS. so thanks for the help. hehe this beats playing it on the PS2 way better graphics woot
CPU: AMD PHenom 8750 Triple-Core 2.4GHz
RAM: 4MB
DX: DirectX 10
Display: ATI Radeon HD 3800 Series 3MB
HDD: 300GB Western Digital
OS: Windows Vista Home 32-bit SP1
Reply




Users browsing this thread: 1 Guest(s)