Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problems with FFX on my computer.
#1
Hi guys, Ive been having trouble running NTSC FFX on 60FPS constant using 0.9.7., since 0.9.6 was giving me loads of problems. I have the hardware to do so too.

Athlon II X3 - 2.7ghz triple core
MSI 870A-G54 gaming motherboard
PNY Geforce GTS 250 1GB
640GB HD
2 X 2GB G.Skill Ripjaws DDR3 sticks
750W Corsair gaming PSU
All not overclocked, but can if I must.

Shouldnt have much of a problem, but I do. I hear people with 8800's getting constant 60FPS without slowdown. However on my machine, I get 60FPS in the first 20 seconds of the intro and then get around 50's which lags my game. Is there anyway to fix it? I was using all the different graphics plugins that came with the emu and all were giving me the same thing, except for one of them, which was giving me 200FPS, but no vsync, so I know my machine is capable of handling it fine. I was checking speed fan to see if my cards were overheating, but it was all fine, at full load, my gpu was running 130F and CPU was at 90F. I mean, my computer can run crysis on max settings at 1440X900, so shouldnt a PS2 game be a walk in the park, even with it being an emulator? Any help is appreciated. Thanks!
Reply

Sponsored links

#2
post your pcsx2 settings (screen shots)

even if you can play metro 2033 on max it has nothing to do with emulation xD
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#3
PC games and pcsx2 are on 2 different levels. PC games rely more on the graphic card whereas pcsx2 depends more on the CPU. If speed is a problem, try using some speed hacks or just Overclock your processor a bit to get full speed.

Can we stop mentioning Crysis, I think we have more than 100 thread comparing it to that, that game is very popular it seems >_<
Intel Core i7 920 @ 3.6Ghz
6GB DDR3 RAM
Nvidia 275 GTX Co-Op
HDD 2x750GB Raid 0
Mobo - Asus P6T
OCZ Game XStream 700W
Window 7 Ultimate
Reply
#4
[Image: graphicssettings.th.jpg]

what else should I post up?

Also, Crysis IS a graphically taxing game. haha. Not many people can play it on max settings yet, without forking over loads of cash for a strong video card. lol.
Reply
#5
yes, and Pcsx2 is not crysis, Youre comparing oranges with nuclear submarines (the nuclear submarine being Pcsx2). You're using ZeroGS, which is quite old. Use the newest version of GSDX, and the .0.9.7 beta pack on the downloads page.
Reply
#6
how come it says I cant use GSDX SSE3 or 4? I can only use 2, and it still lags a little bit on lowest settings. Maybe PAL version works better??
Reply
#7
amd cpu's can use only sse2 and not ssse3 or sse4.1

usually ntsc games are more bug free (from i see in the compatibility list) but 2% slower on speed (not like you will ever see the difference of that 2%)
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#8
is there a way for me to be able to play lag free? I guess overclocking like 10% should be good right?
Reply
#9
use speedhacks experiment with pcsx2 settings etc and yeah an 20% OC would be good

yes i said 20% Tongue
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply




Users browsing this thread: 1 Guest(s)