Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
shadow of the colossus problems everywere need help
#1
HELLO.  im new to pcx2.  just started using it a few weeks ago.  soo far  i had much success getting it to work too.

however.  i seem to be stuck on fixing the popular issues that come with shadow of the colossus. 

here are my problems. 

when i set the resolution higher then 2x native.  the games FPS will be 10-20.  im not really concerned about this as i think it looks fine on 2x native.
however.  when i set the resolution to 2x native.  i get the famous bloom glitch.  (sky is too bright)  and i get black bars on the right and down sides of the screen.

i did some research.  and i found out i can fix the black bars glitch by turning pixel offset too 1.   and i learned i can fix the bloom glitch by setting the resolution to a custom 1024x1024.   however i seem to be unable to fix both at the same time. 

when i have the resolution set to 2x native i get the bloom glitch. and when i have it set to 1024x1024 i get black bars. (no matter what my pixel offset is at)

also.. i am unable to use any speed hacks. as it seems to make the game even slower

sooo im stuck.  any suggestions?

system specs.

os: windows 10 64 bit.
cpu: intel i7-4790
gpu: AMD radeon r7 370
ram:8gb
Reply

Sponsored links

#2
You could try the openGL renderer and 2x native. The bloom is generated due to float rounding. OpenGL will round the value differently. It could be worst, or it could remove it completely.

Note: openGL could be slow on AMD driver. For SoC, you could try to disable accurate blending and/or depth emulation.
Reply
#3
(02-22-2016, 12:49 PM)gregory Wrote: You could try the openGL renderer and 2x native. The bloom is generated due to float rounding. OpenGL will round the value differently. It could be worst, or it could remove it completely.

Note: openGL could be slow on AMD driver. For SoC, you could try to disable accurate blending and/or depth emulation.

thanks for the reply..   i tried openGL  it fixed the bloom but it made the game really slow.  i suppose its because of my AMD driver.

i did however find a fix.  i switched the CRC hack level to aggressive.  that seemed to have fixed the issue by removing the bloom all together.  which looks fine to me.

thanks again man.  i love this emulator.   it takes some tweaking, but it beats 480p on a 1080p screen any day of the week.
Reply
#4
Quote: i tried openGL it fixed the bloom but it made the game really slow

Quote: Note: openGL could be slow on AMD driver. For SoC, you could try to disable accurate blending and/or depth emulation.
Reply
#5
yes, i am aware of the fact you told me openGL might make my game slow because of my AMD driver.

i was gonna contribute to this forum and even ask if there was a way i could donate ....but sense you didn't really give me a logical solution,  and gave me a rude (see i told you so!) reply after i been nothing but humble and polite.  i decided against it.

good day to you sir.
Reply
#6
It's sad to see that people are easily offended these days Tongue

Quote:i did however find a fix.  i switched the CRC hack level to aggressive.  that seemed to have fixed the issue by removing the bloom all together.  

The only difference is that HW depth accurately emulates the effect whereas setting CRC Hack level to aggressive simply skips the drawing of the troublesome depth textures. so it eventually results in better speed. (just in case if you're curious)
Reply
#7
Quote:Note: openGL could be slow on AMD driver. For SoC, you could try to disable accurate blending and/or depth emulation.
The sentence ought to be read as "if you driver is too slow, you can try to disable the options accurate blending and/or depth emulation". It was far from a RTFM.

Anyway, I think the game requires accurate blending for the bloom but I'm not sure. So yeah, better to use aggressive CRC. Fwiw, I'm GPU limited (GTX760) on this game, even on 1x, no pp shader
Reply




Users browsing this thread: 1 Guest(s)