Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
slow downs even though FPS is good
#1
I'm trying to run Pro Evolution Soccer 2010 and am experiencing slow downs from time to time. It doesn't seem to have to do with the FPS, since it is exactly the same even if I don't run on native settings (same result and same good fps with 2048 internal res).

I'm using frame limiter and even if it reads out 50 (max limit) it still can sometimes slow down. I tried turning off the sound but that didn't help either.

Is this something that can be fixed or are these slow downs impossible to get away from? I've tried speed fix settings too, but since my FPS is good even when the slow down occur I shouldn't have to touch those, right?

System:
Core i7 920 @ 2.67 GHz
6GB RAM
GTX 260

Any ideas?
Reply

Sponsored links

#2
Disable vu cycle stealing.
Reply
#3
@Parabol
Fishkopf must be right, what defines the motion perception is not only the number of times a frame is exhibit but the number of actual changes in each frame.
Abusing the VU cycle stealing is stealing the number of things happening, hence the impression of lag.

Still, that is something 'you' must decide, what is better, low raw fps, lag here and there...

I don't know that specific game, and I don't know what are the hacks that works better with it or how hard it is on the CPU and GPU. Yours are good, both, but may be not enough for some games.

In the end it is the game and not PCSX2 that defines the raw power needed from the machine. Much alike the native PC games themselves.
Imagination is where we are truly real
Reply
#4
(08-04-2010, 12:24 AM)parabol Wrote: I'm trying to run Pro Evolution Soccer 2010 and am experiencing slow downs from time to time. It doesn't seem to have to do with the FPS, since it is exactly the same even if I don't run on native settings (same result and same good fps with 2048 internal res).

I'm using frame limiter and even if it reads out 50 (max limit) it still can sometimes slow down. I tried turning off the sound but that didn't help either.

Is this something that can be fixed or are these slow downs impossible to get away from? I've tried speed fix settings too, but since my FPS is good even when the slow down occur I shouldn't have to touch those, right?

System:
Core i7 920 @ 2.67 GHz
6GB RAM
GTX 260

Any ideas?

You may find this information helpful, as it pertains to your CPU:
http://www.tomshardware.com/forum/256144...king-guide
My PCSX2 Rig:Windows XP x32 & Windows 7 x64.
i5 2500k @ 4.0 GHz.
nVIDIA GTX 460 1 GB.
>Dun Click Here<
Reply
#5
(08-04-2010, 01:29 AM)nosisab Ken Keleh Wrote: @Parabol
Fishkopf must be right, what defines the motion perception is not only the number of times a frame is exhibit but the number of actual changes in each frame.
Abusing the VU cycle stealing is stealing the number of things happening, hence the impression of lag.

Still, that is something 'you' must decide, what is better, low raw fps, lag here and there...

I don't know that specific game, and I don't know what are the hacks that works better with it or how hard it is on the CPU and GPU. Yours are good, both, but may be not enough for some games.

In the end it is the game and not PCSX2 that defines the raw power needed from the machine. Much alike the native PC games themselves.

I also have similar slowdown problems and I'm pretty sure I don't use VU cycle stealing, but I'll double check that later.

Was playing SVR2010 and I had an fps of about 60 with disabled frame limiting, enabled it to 45 (want a slower pace) but occasionally (a couple of minutes apart) the fps drops to about 30 which gives an impression of disturbing lag.

Is this slowdown a usual known problem?


My specs:
i7 720QM @ 1.6GHz TURBO BOOST @ 2.8GHz
6GB RAM
NVIDIA GEFORCE GT 230M

I find that going into the task manager and selecting 2 specific cores (that don't have the same physical core) to run the emu on optimizes the performance of PCSX2 for me. I can't disable hyper threading since there is no BIOS option for this sadly.
Also I found that using the US NTSC 1.6 version BIOS gave me a higher framerate than v2.0 or the PAL 1.6.

Some settings:
EE/IOP
EE: Recompiler
IOP: Recompiler
Advanced
Round Mode: Nearest
Clamping Mode: Normal
Flush to Zero: V
Denormals are Zero: V

VUs
VU0: superVU Recompiler
VU1: superVU Recompiler
Advanced
Round Mode: Chop/Zero
Clamping Mode: Normal
Flush to Zero: V
Denormals are Zero: V

GS
Framelimiter
Base Framerate: 100%
Slow motion: 50%
Turbo: 200%
NTSC: 59.94FPS
PAL: 45FPS (I run the game in PAL mode)
Frameskipping disabled

I have tried different texture sizes but I get the same lag no matter if I run with native or high textures.

Any suggestions?
Reply
#6
i used to have the same problem on pes 2010 until i bought the pc version,get it its much better.
And if you want to know whats happening with pes2010 i think that this game have a bug in pcsx2
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply




Users browsing this thread: 1 Guest(s)