Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved] GS plugin fails to open with Nvidia
#1
Hi! I have a notebook with both a Intel HD Graphics 520 and a Nvidia GeForce 930M. I use bumblebee to run applications with the nvidia gpu. When I run PCSX2 normally, with the Intel graphics, the game runs normally, but when I use the Nvidia card, PCSX2 gives me the following message:

"GS plugin failed to open. Your computer may have insufficient resources, or incompatible hardware/drivers."

And in the console:

Failed to create the opengl context. Check your drivers support openGL 3.3. Hint: opensource drivers don't
"GS plugin failed to open!(thread:MTGS)(thread:EE Core)"


I'm using the latest nvidia driver with GSdx plugin. Running other applications with Nvidia works alright, only PCSX2 gives me a problem.

Can someone help?

Edit: I found the solution. lib32-primus was not installed. It's required if you use bumblebee
Reply

Sponsored links

#2
Check PCSX2 console. You will get some messages of the not supported feature.
Reply
#3
I get this:

Failed to init the freetype face
Failed to create the opengl context. Check your drivers support openGL 3.3. Hint: opensource drivers don't

But I have freetype installed and I'm using the proprietary nvidia driver, which supports openGL 3.3. I tried to install lib32-nvidia-libgl instead of lib32-mesa-libgl, but now it does not work with neither Intel or Nvidia
Reply
#4
As soon as I replied I remembered vaguely having this problem in the past and then the solution came.. if you use bumblebee like me, you should keep lib32-mesa-libl and install lib32-primus
Reply
#5
Mark the thread as resolved
Reply




Users browsing this thread: 1 Guest(s)