Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(solved) Soul calibur 3 - the heavy one
#1
Hi, I tried everything I could to emulate this single game, the only one I really care about.
On my real phat ps2 it works like a charm (of course).
But with pcsx2 I can't get it working.
Tried with many svn, different plugin combos and settings, followed emulation progress (i.e. vertical black lines with non native resolution and hw render).
On latest svn it works good, but... I always have frame drops.
FPS counter is on 59.94, but they are noticeable. They are there even without post processing and on native res. With or without speedhacks.

My PC is not so crappy: i5 6600k @ 4.2, 16gb, gtx1080.
It's really so demanding that game? EE is such a bad boy?
Reply

Sponsored links

#2
Check to see if vsync is on in Emulation settings -> GS window. Turn it on if it isn't.
Reply
#3
I'm confused.  What do you mean by you can't get it working?  It won't play?  The graphics are messed up?  It's running to slow?  What exactly is going on?  I have no problem running the game @ constant full speed using native resolution to remove the black lines.  Using current dev build
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
16 GB DDR4 RAM
Reply
#4
(11-17-2016, 02:38 AM)envisaged0ne Wrote: I'm confused.  What do you mean by you can't get it working?  It won't play?  The graphics are messed up?  It's running to slow?  What exactly is going on?  I have no problem running the game @ constant full speed using native resolution to remove the black lines.  Using current dev build

Stuttering.
My problem is I can't remove stuttering and frame drops (for example during throws animation)...

Otherwise runs OK, with latest build you don't need to run at native to avoid black lines...
Reply
#5
Interesting.  I don't experience any stuttering.  And using the most recent git build, I still get the vertical black lines when it's set to anything other than native.  Or I can just use software, but that just uses native also
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
16 GB DDR4 RAM
Reply
#6
Are you playing directly from the game disc? If so that can cause stuttering, it's recommended you make an ISO using ImgBurn and run the game from that.

If that's not the case, can you show us all of your emulator settings (theres a little camera in the bottom left to help you take screenshots here) and your GSDX and SPU2-X settings please Smile

Possibly even a screenshot of the game when it's stuttering if you can!
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(11-17-2016, 01:42 PM)refraction Wrote: Are you playing directly from the game disc? If so that can cause stuttering, it's recommended you make an ISO using ImgBurn and run the game from that.

If that's not the case, can you show us all of your emulator settings (theres a little camera in the bottom left to help you take screenshots here) and your GSDX and SPU2-X settings please Smile

Possibly even a screenshot of the game when it's stuttering if you can!

First of all many thanks for all of this answers.
It's awesome how people try to help perfect strangers this way, but evidently when something is more than just fun but it's a passion this is gonna happen.

Ah! And sorry if I wrote something wrong, english is not my first language, I write from Italy.

Going back to SC3, it seems that checking the v-sync option apparently fixed the problem. Strange, because I thought that v-sync related issue would be more tearing-like, and what I had was real stutter / frame drop.

No time now to extensively try it out, but I did a 3 match play without noticing anything strange. On the contrary, I enabled back 2x native resolution and was able to inject ReSahde to gain "HDR", vibrance, CRT effect, a light bloom and some other improvement over original PSX2 gfx capabilities.

Btw I'm using a iso.

I'll update ASAP when I'll test everything a little more, for now and for future reference of other users also, this is my actual config (do you think is it right?):

PCSX2 1.5.0 dev 1599
EE/IOP default
VU default
GS default
GS window wait for vertical sync, others default
Speedhacks active, EE 0, VU Cycle stealing 0, INTC Spin, Wait Loop Detection, micro VU Flag all checked, fast CDVD and MTVU unchecked - I think this should be default as "safe preset"
Gamefix none checked

Gfx plugin 3d9 Hardware
8 bit textures off
Large framebuffer on
Res 2x native
Texture filtering Bilinear
Anisotropic off
Mipmapping off
CRC Hack full
Enable HW hacks on with just "align sprite" selected
Logaritmic Z on
Alpha correction on
Shaders only with FXAA

Reshade with only sweetfx enabled (see attachment for settings)


Attached Files
.zip   SweetFX.zip (Size: 7,79 KB / Downloads: 12)
Reply
#8
Mmmmh sorry I was wrong I have also wild arms hack enabled.

But I noticed characters don't have any shadow... strange... No skipdraw set up.
Reply
#9
(11-17-2016, 03:33 PM)franzlanz Wrote: Going back to SC3, it seems that checking the v-sync option apparently fixed the problem. Strange, because I thought that v-sync related issue would be more tearing-like, and what I had was real stutter / frame drop.

In newer Windows versions, vsync for non-exclusive applications is enforced through the DWM. For some reason, having vsync off in PCSX2 can lead to really poor framepacing. While the emulator might run at 60fps, some frames will be duplicates, others will be dropped instead - stuttering, in other words.
Reply
#10
(11-17-2016, 07:33 PM)Eloris Wrote: In newer Windows versions, vsync for non-exclusive applications is enforced through the DWM. For some reason, having vsync off in PCSX2 can lead to really poor framepacing. While the emulator might run at 60fps, some frames will be duplicates, others will be dropped instead - stuttering, in other words.

I see. Thanks.
Any idea for shadows not showing?
Reply




Users browsing this thread: 1 Guest(s)