Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
solved: periodical lagging
#1
Hi guys,

i'm using this emulator for almost two years and my notebook was always fine with it:

CPU: T8300 2x2,4 GHz
GPU: Nvidia 8600M GS
RAM: 4 GB
Win 7 x64, --> DX10/11

PCSX2 0.9.7 beta Web installer r3876
gsdx 3693 sse4.1 0.1.16 dx10(hardware) [gsdx-sse4-r-3878]
LilyPad r3878
SPU-X r3702
cdvdgigaherz r3429


I know that these are not optimal conditions but with some speedhacks i almost had 100% fps for FFX, FFX-2,...

Last month my graphics crashed and i returned the notebook to developer for repair process... now i got it back and everything is fine except pcsx2.
Repair Report: new board, bios update

now i can't enjoy gaming because the emulator is lagging ~6-8 fps but not all the time.
at first the emulator works properly after 30 seconds the first lag appears (6 fps) for 5 seconds, then properly for 15 seconds, lagging for 10 seconds, 5 seconds properly, and now its almost all the time lagging.
from time to time the frames increase to 100% but only for 2-3 seconds

the lagging is not connected to the shown content, its also lagging in the save-menu

in this time my cpu and ram are bored, cpu,ram~30-50%

first i tried to change the gs-plugin
but its the same problem with gsdx9, gsdx10, gsdx10sse2,..., zerogsExcl
so i (hopefully) can tell that there is no problem with gs-plugin
Only one thing was strange: restarting the gs-plugin fixed the problem for some time. But i dont want to restart/change gs-plugin all the time...

then i tried to change isoplugin, but both plugins (iso-mode and direct dvd-rom-mode) have the same problem
so i (hopefully) can tell that there is no problem with iso-plugin, too

then i deinstalled my virus-protection, closed all other applications, with no better effect

next step would be reinstalling windows. is there any other chance?

by the way currently im using FFXII to test, but same problem with Kingdom Hearts II

i dont know what tag i should use for this problem for search function. i hope that this subject isnt known, and every to seconds an idiot opens a thread like mine.

and excuse my writing, im not speaking english very well...
Reply

Sponsored links

#2
best would be to check your POWER settings on your pcm and see if it's been downclocked by windows, which (sometimes) techs do when testing hardware and often forget or intentionally do not speed it back up. that's the first place to check. the second is your emulation settings and speedhacks.
Reply
#3
That was some weird advise, Saiki.
It's obviously an overheating problem of sorts.
The notebook gets too hot now due to some change they did and the hardware protection kicks in.
Maybe the new BIOS simply has a lower heat threshold for GPU heat?
(This is something Nvidia recommends doing after they found out that their chipsets fail in many notebooks.)
Reply
#4
It's what I advise people to do that talk to me directly, and my PC is set to 100% cpu at all times, it never drops from 100% usage. thus pcsx2 (and other apps) never hit lag spikes that are frequent and annoy the hell out of me. (much like this would)
And trust me when I say, I've seen this happen before, and it was not an overheating problem, thus my advice.
Reply
#5
i'm not sure but i think its not an overheating-problem
i've had many overheating problems because of using my laptop on my trousers and stuff like this.

now im using a really well-working extern laptop-cooler. i also think that they cleaned my intern-cooling-system, because my notebooks doesn't become very hot.

But the symptoms are the same.. maybe you're right and they set he overheating temperature to 30°C ;-), can i check this in bios?

@ saiki

where can i check the power settings? Do you mean Windows-Power-Setting like "Energy saver" "High Performance" and "balanced" or do you mean bios power settings?

Speedhacks have no bad effect, same problem without them, only a little bit slower...
Reply
#6
Bios update could mean different behavior with speed step or throttling of some sorts, check in your BIOS to see if you have any option to disable that. To confirm it's this, download and run CPU-Z and check the processor frequency while running PCSX2 at the points when you get the slowdowns
[Image: newsig.jpg]
Reply
#7
did the rename it.. I forget.. but yes, the windows options.
Reply
#8
ok... cpu-z detected that the clocks of gpu are increasing in time of lagging (sounds strainge?!)

pcsx2 works:
Core: 275 MHz
Shaders: 550 MHz
Memory: 301 MHz

pcsx2 laggs:
Core: 500 MHz
Shaders: 1000 MHz
Memory: 700 MHz

but these are normal values:
Source:nvidia.com
Core: 600 MHz
Shaders: 1200 MHz
Memory: 700 MHz

CPU keeps its clock/voltage-settings
Reply
#9
then it's probably a driver issue, try updating your drivers at nvidia's site.
Reply
#10
(10-29-2010, 07:12 PM)Saiki Wrote: then it's probably a driver issue, try updating your drivers at nvidia's site.

drivers are up2date

ive checked it before creating this thread

there could be newer beta-driver but i dont really want to test them...
Reply




Users browsing this thread: 1 Guest(s)