Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
sound and graphics issues
#1
I am extremely new to PCSX2. I fought for the better part of a day trying to mess around to get it to just work in the first place. I have it kind of working...... but not well. The game that I am currently trying to run is Soul Caliber 3.


Model Name: MacBook Pro
Model Identifier: MacBookPro5,2
Processor Name: Intel Core 2 Duo
Processor Speed: 2.8 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 6 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP52.008E.B05
SMC Version (system): 1.42f4

That is my computers stats. The game runs at a very slow frame rate and I cant get the sound to run properly.. its very choppy. I'm thinking that somewhere in my configurations im having issues or perhaps its my plugin's any help would be great. Also I cannot go full screen either as the sides of the screen do some very funny things. Im thinking that this computer should be doing a little better than 5 or 6 frames per second.

PCSX2 Config

Graphics ZZ Ogl (DEV) 0.17.156
Sound P.E.OP.S SPU2 SDL 1.9.0

Suggestions ?

So after playing with just about every option I am at a loss. It plays the introduction video awesome. As soon as you try to play the game frame rate drop sound goes all messed.

P.S. does anyone know how to change the info shown on the top of x11 when running games ?
Reply

Sponsored links

#2
Where did you get this ancient version? Please download the latest 0.9.6 from official website and use zerospu2 sound plugin instead of peops.
Reply
#3
I have 0.9.6 but SPUNull is the only other sound option, and it does not work at all. Im not sure if that is the same as zerospu2 or not.
Reply
#4
0.17.156 is definitely not current zzogl, that's why my guess is you are using old pcsx2, the new ones are with 0.19.195.

Zerospu2 requires portaudio package which can be installed from binary repository page on official site
Reply
#5
alrighty then im gonna redownload pcsx2 and get Zerospu2 and see what happens.
Reply
#6
Well im all updated. It's way better Thanks ! However i still have some issues.

Im running
graphics ZZOGL 0.21.204
Sound ZeroSPU2 Playground 0.4.6

These are a couple of the lines in Terminal that I picked out, don't know if they are normal or not.

Xlib: extension "XFree86-VidModeExtension" missing on display "/tmp/launch-w4Z5Cm/org.x:0".

ZZogl: Shader file version is outdated! Only is log-Z possible

ZZogl: Failed to create bitmask texture; ZZogl: bitmask cache; 0 ZZogl: Invalid enumerato
pcsx2(932,0xb0103000) malloc: *** mmap(size=18350080) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
pcsx2(932,0xb0103000) malloc: *** mmap(size=18350080) failed (error code=12)
*** error: can't allocate region

pcsx2.sh: line 2: 932 Bus error ./pcsx2

Last line caused a crash.

Thanks for the help !
Reply
#7
Does it happen when you start the game, randomly or at the same point in the game?
Reply
#8
Xlib: extension "XFree86-VidModeExtension" missing on display "/tmp/launch-w4Z5Cm/org.x:0".

ZZogl: Shader file version is outdated! Only is log-Z possible

Those 2 happen at the same point. Happens at the start right after i try to load the iso file.

ZZogl: Failed to create bitmask texture; ZZogl: bitmask cache; 0 ZZogl: Invalid enumerato
pcsx2(932,0xb0103000) malloc: *** mmap(size=18350080) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
pcsx2(932,0xb0103000) malloc: *** mmap(size=18350080) failed (error code=12)
*** error: can't allocate region

pcsx2.sh: line 2: 932 Bus error ./pcsx2

These 2 happen at random points during the game. And they dont always happen either.
Could it be a localized problem with this particular game ?
Reply
#9
it's seems like standart error, that was fixed in r208 (incorrect wrapping for TEXTURE_RECTANGLE_NV).
Reply
#10
Ok so does that mean that I have something that is outdated ?
Reply




Users browsing this thread: 1 Guest(s)