Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
sound is too fast in cutscenes
#1
as the title suggests,when a cutscene is being played,the sound get out of sync and it comes before the video,which means that I will see an explosion around 2-3 seconds after I have heard it.

the games I've noticed that effect in were

final fantasy x-2
haunting ground
grandia 3

which pretty much sums up my whole "played" list of games with the emulator

I've also played odin sphere but there's no issue with sound there

in final fantasy x-2,the problem wasn't so obvious...it was happening but it wasn't so severe.

in haunting ground it was waaaaay worse...the sound in every cutscene was ahead of the video and it was getting worse as the cutsene went on

in grandia 3(what I'm currently playing) the same issue persists and this is where I got fed up with it.

also,in grandia 3,I've noticed that when walking around in the world,I get a visible drop in fps,in some places, but the counter in the window says 57-62 frames which is ofcourse not the case...and to top it off,the music keeps playing as if there's no slowdown at all even if I have timestretch option in sound menu.

I've also tried playing around with the latency slider in sound but all it did was make the "in game" sounds come after I see them in the video and had no effect in cutscenes

that problem happens ONLY in cutscenes.

my system is

windows 7 32 bit ultimate
athlon x2 5600+
radeon 4850 512mb
2 gb of ram
pcsx2 version 1.0.0

old? oh yes but it still gets the job done

I've also attached pics of my configuration,I know that the hacks might be a little extreme but without them,games ussually run at 70-80% of speed...there's a very high chance that the problem is there but some games are just unplayble without them.

any help? thanks in advance!


Attached Files Thumbnail(s)
           
Reply

Sponsored links

#2
think about disabling MTVU hack since your CPu won't take advantage of it most of the time.
Lower VU Cycle stealing and increase ee cycle rate a bit.

But yeah, the speedhacks settings you've chosen are likely to cause this.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
well...here's an interest result

I put VU cycle stealing to 1 and EE cyclerate to 2 while unchecking MTVU hack

fps in battles was around 45-50 (max of 60)

when I enabled MTVU the fps shot to around 70 for a second till it got limited to a rock steady 58-61

bit weird since it says it helps systems with 3+ cores

anyway

the big news is that I watched 1 cutscene so far and it was perfect!
there was a bit of a slowdown while playing it but this time,the sound stayed in sync with the movie the whole time even if it sounded slow at places.

it would seem that VU cycle stealing over 1 will break sound even if you have timestretch option enabled?
Reply
#4
try viewing cutscenes in software mode by pressing f9 then when it ends press f9 to go back to hardware mode

cool nick name :-) you must like legacy of kain games. Did u play them all?
Reply
#5
software mode is baaaaaaaaaad for me...like 25 fps bad lol

I also viewed a cutscense with VU cycle stealing at 1 and sound was spot on
I then loaded my game and viewed the same cutscene with VU cycle stealing at 2 and sound was still spot on....THE PLOT THICKENS

maybe it only gets out of sync when I'm not running at 100% of speed,but VU cycle stealing at 1 is able to sync the audio while VU cycle stealing at 2 doesn't.

I've only played soul reaver 2 and the next legacy of kain game that came out...the one that you played as kain.
raziel could be the coolest name ever thought of and I've copyrighted it for every game/forum/account I will ever use so don't think of using it Tongue2
Reply
#6
here's some more results.

I used VU cycle stealing at 1 and went to a heavy graphically area....my fps dropped to around 50-52(max of 60),I could see it that the game run slower and the sound went slower as well

at the same area,I used VU cycle stealing at 2 and while the fps counter said 58-60 fps,the game was running AS SLOW AS BEFORE(50 fps) but now the sound was playing as if there was no slowdown at all.

has anyone else ever come across something like this?
Reply
#7
Find what works for u

Btw did u understand the plot? In end of 2 the sword wanted to devour raziel but kain saved him. In next game u play as kain. What of the final game? I think its called defiance. Did u play it?
Reply
#8
nope....sound is still being played before the cutscenes even with VU cycle stealing at 1.
it only happens when a cutscene can't be played at 100% speed but isn't that what timestretch is supposed to fix?
Reply
#9
if you disable speedhacks, how is the sound ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#10
using only the recommended speedhacks,game plays at around 60% of full speed in battle and is completely in sync with the sound.

I also replayed the cutscene I mentioned above and got a steady 100% speed with sound staying in sync with the video.

if speedhacks are what's causing this to happen then I believe that I'm gonna have to just deal with it since games are pretty slow without them...that or get a new pc -.-

is there ANYTHING else anyone would like to add?
Reply




Users browsing this thread: 1 Guest(s)