Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
svn builds and auto changing folder settings
#1
Exclamation 
after a long time (200 revs almost) i tried again the newest svn of pcsx2, i configured it step by step (but i selected folders ONLY in program files (x86) cause thats how/where i like to keep my pcsx2 and everything it needs)
i changed the path in the starting setup and i also changed the path in the folders option (at plugin/bios selector menu) and everything went fine.

so i closed the emulator and deleted the &$#%$#@ folder it created in "my documents" ( i use win 7 x64) without asking me [i find this very annoying].

next i opened the emulator again only to find that my changes in the folders I wanted it to use where gone.

i understand you want to avoid problems with folder rights etc BUT there are also ppl that DONT have those kind of problems (cause of the settings they use or the account they use in their windows OS).

before that $%^$# thing you had a VERY nice option in the 1st screen of setting up pcsx2 (when you first run it) where you could choose to use the default folders (my docs) or the folders we want (or where the pcsx2.exe is located) and everything was nice and cool... BUT now it just keeps annoying me cause it doesnt want to use the folders I WANT it to use...

i hope you take my problem in consideration and do the appropriate changes to keep both problems away (folders rights problem and my problem).

ofc i accept any/all questions/opinions about it so we can discuss the matter ^^

thank you.
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply

Sponsored links

#2
run the emulator with the command --portable, that will use the current directory. It annoyed me too xD

so itll be:

pcsx2.exe --portable

and that will solve it Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
will this have any changes in the way the emulator behaves? (or new bugs? Tongue)

edit: already tried it and now it works like the old days Laugh
thanks you for your help, but what about other users that dont know about this command? i mean there will be any "easier" to find/use option?

edit2: there should be an auto merging option in the forums that when you add a reply, IF you are the last one posted, that it will auto merge your messages (with this way it will seem like someone posted a new message but it will look like 1 message BUT edited)
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#4
Umm.. Im not sure to be honest Tongue Im not working on the GUI side of things, i can certainly suggest it to the folks who are. However what i had in mind was the ability to choose where it goes instead of being forced to use my docs
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
yep thats totally cool Wink
something like the method used before maybe or something more simple, well you guys probably will find a good way to deal with it Wink
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply




Users browsing this thread: 1 Guest(s)