Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
two questions
im new here so i would like to say hi to you all

my first question is: would a Radeon HD3650 be good enough to run the emulator i have searched and i have found out that when you play game X it runs smoother then game Z becoase game Z needs a better video card
the games i want to play are:
Devil may cry
Devil may cry 2
Devil may cry 3
metal gear solid 2
metal gear solid 2 substance
metal gear solid 3
Kya dark league

my setup is:
Processor: Intel® Pentium® D CPU 2.80GHz (2 CPUs)
Memory: 1790MB RAM DDR2 533 MHZ
Hard Drive: 400 GB
Video Card: ATI RADEON XPRESS 200 Series
Monitor: hp pavilion mx70
Sound Card: Realtek HD Audio output
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp.080413-2111)

i can run the main PS2 menus in a framerate of 60-70

my second question is: if i use an ISO which i made (with magicISO) from one of my games (devil may cry) in i try to play it i keep getting "please insert a playstation or playstation 2 format disk" or the disk appears and i try to access it i get a black screen for a few seconds and then it returns to the menu with the two memory cards what gives ?

Sponsored links

First, pcsx2 emulation depend with Cpu than grapich card to play properly. Second, for your problem about ISO file, seems you make an ISO game not in the right way. Try to make ISO game with daemon tool pro program or nero or UltraISO PRogram.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
Your system is way too slow to run PCSX2 decently with acceptable framerates. Maybe if you tried lowering everything and applying all speedhacks and stuff.

I'm on almost the same system except with a 3.2Ghz processor, the Radeon 200 Xpress really sucks and is onboard, so it's limiting you most of all.
.:Intel Core i7 Extreme 965 OC'ed @ 4Ghz - EVGA X58 SLI - Corsair 6GB @ 1600Mhz 9-9-9-24 - 2xEVGA GTX 285 1GB OC'ed @ 680/1548/1270Mhz in SLI - Dell UltraSharp 24" - Corsair HX1000W PSU - Noctua NH-U12P SE1366 - Antec 900
.OhmyCZ Vertex 250GB SSD 200/160MB/s read/write - Samsung F1 1TB
.:Windows 7 x64
i have turned on nearly all of the speedhacks and running in windowed mode +/- 680x460
also when i mount a backup iso and i select the disk it does say that its a playstation 2 disk

i guess i forgot to mention that

Users browsing this thread: 1 Guest(s)