Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
weird graphic corruption for arcana heart 2
#1
i've recently gave the game a try in pcsx2, and while it seems to be fine on the first glance when you look closer the sprites look pretty damaged with all the random stray pixels all over the character sprites and portraits, as if someone saved them as jpg, then reapplied original palette and resaved as original format.

zoom in at the attachment to see what i mean.
   

it's not plugin problem because the corruption happens on both gsdx and zerogs, and it also happens only for this game. i hear from other people who have it that they don't get this problem though, and it looks just fine when i try it on my ps2, so it can't be a damaged disc either (i doubt scratches could create this kind of problem anyway).

it also can't be corrupted directx drivers, i reinstalled them few times, but the problem was there even after a windows reinstall i had to do few days ago.

for the record, amd sempron 3000+, geforce fx 6100, 2 gb ram.

btw. i've been wondering, could it be possibly caused by this?
Quote:******
GS ERROR: Device doesn't support alpha blending for 16bit floating point targets.
Quality will reduce.
*********
Reply

Sponsored links

#2
an outdated video card which doesn't support alpha blending for 16bit floating point targets? Wink
Reply
#3
yeah, i really need to upgrade this pc sometime. is that what causes the problem?
Reply
#4
Enable Texture Filtering from GSdx and use another Interlaced mode or disable it,also try with Native if you use custom resolution.
And about the error,are you using 256bit colors from properties on the pcsx2=>Compatibility?
Reply
#5
yes and poor frame rate we see in the picter show us you have a weak pc
Reply
#6
Quote:Enable Texture Filtering from GSdx and use another Interlaced mode or disable it,also try with Native if you use custom resolution.
And about the error,are you using 256bit colors from properties on the pcsx2=>Compatibility?
texture filtering makes everything ugly and blurry. 2d games look terrible with filtering.
as for interlace, i need it. other modes either make everything blurry or the lines are all wrong. with the interlace disabled the screen bobs up and down and the graphics lose their resolution and become 2x more pixelated.
i always run things in native resolution.

and nope, no compatibility settings. 256 color mode would make it look way worse. the backgrounds and character portraits wouldn't look this colorful. the character sprites themselves use 256 color palettes each.
Reply
#7
just upgrade your pc
Reply
#8
yeah that's the plan, i'll eventually have to buy a new graphic card since the one i have is built in.

i really only use this pc for browsing internet, coding some stuff and doing silly things in pcsx2/other emulators that i can't in a real console like that screenshot in which i took control of the final boss so upgrading it isn't my priority.
Reply
#9
Start the game enter in some battle(like on you screen shoot)and press Shft+F8.Then you'll find in snaps folder 2 or 3 files(bmp,obj and gs).Archive all of them and upload them somewhere.That's way I can see if your problem is your error or the game is working on pcsx2 that way.
Reply
#10
as you wish . he have built in graphic card so his graphic card and his cpu i think
Reply




Users browsing this thread: 1 Guest(s)