[1.7.3903] Steam Overlay not working, and Steam Input not activating
Precisely as title describes. I've added launch arguments to Steam to auto start it into a game with fullscreen, I've tried both the AppImage and the Flatpak to see if it was a sandboxing related issue, I've switched desktop environments, I've switched between X11 and Wayland backends, I've tried running it with Steam in desktop mode, BP mode, even new BP mode with the appropriate flag, it will not register that PCSX2 is open.

OS: Arch (EndeavourOS)
Desktop Environments tested: XFCE, KDE Plasma X11, KDE Plasma Wayland
GPU: NVidia 20 series, latest driver

Those should be all the relevant details, nothing else I can think of that should have an effect on this behavior.

If anybody's curious why I need it, I'm trying to chop the analog deadzone out of Gran Turismo 4's throttle and brake controls, I get it's meant to be for pressure sensitive buttons but I have full range granular triggers I can use, and Steam Input can let me set up an anti-deadzone to fix it. I could map the right stick up and down to the triggers, but I'm not fond of that solution, since it puts both triggers on a single axis.

Sponsored links

Same problem at my end.
Would like to use the overlay for the Notepad and simple way to chat with friends (only one monitor).

OS: Pop OS
GPU: Nvidia 30 series

I've read on Steam that it's because PCSX2 doesnt run the game in the same process as the one that you are starting from Steam.
The workaround for them was to create .exe files out of .batch files on windows which were then imported as "non Steam-Games".
Maybe it's possible to create appimages which contain the launch-commands and import them into steam.
But I have no experience in doing anything like that so I can't tell you if that's actually possible.

Users browsing this thread: 1 Guest(s)